summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-11 12:04:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:16 +0200
commit893e3fc1c091fef89ed88f1aa87bd74814cdda08 (patch)
tree0e0d9ff035d46b53130a7fa8cbe7d2ca617c574f /gnu/packages/tex.scm
parent74e9c9a46307a2e2de775ee4a32a53379a03284a (diff)
gnu: Add texlive-latex-filemod.
* gnu/packages/tex.scm (texlive-latex-filemod): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4c3d15419e..f54b8408ee 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1845,6 +1845,44 @@ without affecting the structure of the list (this works for @code{itemize} and
@code{enumerate} lists, and numbered lists remain in sequence).")
(license license:lppl)))
+(define-public texlive-latex-filemod
+ (package
+ (name "texlive-latex-filemod")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/filemod"))
+ (revision %texlive-revision)))
+ (sha256
+ (base32
+ "0vpxilfw69xv78f03g0j0zw0bw4qcn36whqp8phcq48qk1ax2kr2"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/filemod")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/filemod")
+ (synopsis "Provide file modification times, and compare them")
+ (description
+ "This package provides macros to read and compare the modification dates
+of files. The files may be @code{.tex} files, images or other files (as long
+as they can be found by LaTeX). It uses the @code{\\pdffilemoddate} primitive
+of pdfLaTeX to find the file modification date as PDF date string, parses the
+string and returns the value to the user. The package will also work for DVI
+output with recent versions of the LaTeX compiler which uses pdfLaTeX in DVI
+mode. The functionality is provided by purely expandable macros or by faster
+but non-expandable ones.")
+ (license license:lppl1.3+)))
+
(define-public texlive-latex-natbib
(package
(name "texlive-latex-natbib")