summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-09 22:38:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-14 00:18:09 +0100
commit928fc7c5116c3ecd8b9d4487eef0c07c71a43c37 (patch)
tree5ea53f60e879bcb390fffced4f7a83318075f4bc /gnu/packages/tex.scm
parent46fd83031e72a0795ee8380a1e0285746e031c55 (diff)
gnu: texlive-bin: Purge unused bundled software from the source.
* gnu/packages/tex.scm (texlive-bin)[source](modules, snippet): New fields.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3653e1d00c..c9b211ed84 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -266,7 +266,22 @@ copied to their outputs; otherwise the TEXLIVE-BUILD-SYSTEM is used."
"03vc88dz37mjjyaspzv0fik2fp5gp8qv82114869akd1dhszbaax")
(search-patch "texlive-bin-poppler-0.83.patch")
(arch-patch "texlive-poppler-0.84.patch" arch-revision
- "1ia6cr99krk4ipx4hdi2qdb98bh2h26mckjlpxdzrjnfhlnghksa"))))))
+ "1ia6cr99krk4ipx4hdi2qdb98bh2h26mckjlpxdzrjnfhlnghksa"))))
+ (modules '((guix build utils)
+ (ice-9 ftw)))
+ (snippet
+ '(begin
+ (with-directory-excursion "libs"
+ (let ((preserved-directories '("." ".." "lua53" "luajit")))
+ ;; Delete bundled software, except Lua which cannot easily be
+ ;; used as an external dependency.
+ (for-each delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file preserved-directories))
+ (eq? 'directory (stat:type (stat file)))))))))
+ ;; TODO: Unbundle stuff in texk/dvisvgm/dvisvgm-src/libs too.
+ #t))))
(build-system gnu-build-system)
(inputs
`(("texlive-extra-src" ,texlive-extra-src)