summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-08 11:45:40 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-08 12:20:50 +0100
commite09f3cf9b9acf2c8daf1f9f510e288d86b25d282 (patch)
tree781fdbb6324d566ffa711b838d0f6934441aa77a /gnu/packages/tex.scm
parenta1e33b7d8f0bf930281b918414c6139e2043d385 (diff)
gnu: lyx: Update to 2.3.7.
* gnu/packages/tex.scm (lyx): Update to 2.3.7.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 13bc000918..ba6bb4357a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8315,15 +8315,18 @@ and Karl Berry.")
(define-public lyx
(package
(name "lyx")
- (version "2.3.6.1")
+ (version "2.3.7")
(source (origin
(method url-fetch)
- (uri (string-append "https://ftp.lyx.org/pub/lyx/stable/"
- (version-major+minor version) ".x/"
- "lyx-" version ".tar.xz"))
+ ;; XXX: Upstream version is 2.3.7, but they released a suffixed
+ ;; tarball. This can probably be removed after next release.
+ (uri (let ((suffix "-1"))
+ (string-append "https://ftp.lyx.org/pub/lyx/stable/"
+ (version-major+minor version) ".x/"
+ "lyx-" version suffix ".tar.xz")))
(sha256
(base32
- "0y7sx804ral14py5jwmb3icvyd6rsw806dfclw0qx28r6iix5gn6"))
+ "1vfq30big55038bcymh83xh9dqp9wn0gnw0f6644xcw6zdj8igir"))
(modules '((guix build utils)))
(snippet
'(begin