summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-09-02 07:56:04 +0200
committerLudovic Courtès <ludo@gnu.org>2022-09-04 23:10:13 +0200
commite879111c094e4310a13c443317792b3a4e30ddcc (patch)
tree2e0e7e4a009d9b216c2af7b5981919efbf66f9ca /gnu/packages/tex.scm
parent4bbad495a799c99499fa0d3aa87e4915f6ccaf7d (diff)
gnu: Add texlive-latex-hyphenat.
* gnu/packages/tex.scm (texlive-latex-hyphenat): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 212c7eb4a9..80edb64186 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11572,3 +11572,22 @@ use of the fonts in LaTeX (Type 1) and XeLaTeX/LuaLaTeX (OTF).")
Adobe in both Adobe Type 1 and OpenType formats, plus macros supporting the
use of the fonts in LaTeX (Type 1) and XeLaTeX/LuaLaTeX (OTF).")
(license (list license:lppl1.3+ license:silofl1.1))))
+
+(define-public texlive-latex-hyphenat
+ (package
+ (inherit (simple-texlive-package
+ "texlive-latex-hyphenat"
+ (list "doc/latex/hyphenat/"
+ "tex/latex/hyphenat/")
+ (base32 "0b3jx2yvryx95am0ll9h6yc99niw2lwgsbq7r89j84z2qyp2llsq")
+ #:trivial? #t))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/hyphenat")
+ (synopsis "Disable/enable hyphenation")
+ (description
+ "This package can disable all hyphenation or enable hyphenation of
+non-alphabetics or monospaced fonts. The package can also enable hyphenation
+within ‘words’ that contain non-alphabetic characters (e.g., that include
+underscores), and hyphenation of text typeset in monospaced (e.g., cmtt)
+fonts.")
+ (license license:lppl1.3c+)))