summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-18 14:16:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-18 20:28:17 +0200
commit5d2e3b6b23584113b1ccf17130689a3a3562bb6c (patch)
tree36c33ae8824625c69169c5a1862879b210c1e07f /gnu/packages/text-editors.scm
parent7f2b9306eea163391dda6e4cf395a0e2be1be984 (diff)
gnu: mg: Set PKG_CONFIG instead of substituting.
* gnu/packages/text-editors.scm (mg)[arguments]: Add PKG_CONFIG to #:make-flags, and remove the custom 'pkg-config-for-cross-compiling-target phase.
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 2f42d831c0..5a2c7bc20d 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -532,7 +532,8 @@ Wordstar-, EMACS-, Pico, Nedit or vi-like key bindings. e3 can be used on
;; No test suite available.
`(#:tests? #f
#:make-flags (list (string-append "prefix=" %output)
- (string-append "CC=" ,(cc-for-target)))
+ (string-append "CC=" ,(cc-for-target))
+ (string-append "PKG_CONFIG=" ,(pkg-config-for-target)))
#:phases (modify-phases %standard-phases
(delete 'configure) ; no configure script
(add-before 'build 'correct-location-of-diff
@@ -541,13 +542,6 @@ Wordstar-, EMACS-, Pico, Nedit or vi-like key bindings. e3 can be used on
(("/usr/bin/diff")
(string-append (assoc-ref inputs "diffutils")
"/bin/diff")))))
- (add-before 'build 'pkg-config-for-cross-compiling-target
- (lambda _
- (substitute* "GNUmakefile"
- (("pkg-config")
- (or (which "pkg-config")
- (string-append ,(%current-target-system)
- "-pkg-config"))))))
(add-before 'install 'patch-tutorial-location
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "mg.1"