summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2021-02-11 19:12:36 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2021-02-11 19:12:36 +0100
commitabd318ff4b741eac11227778bf2e569ee7b186ff (patch)
tree6abc09a3e01914d891124e9d0dda0f4e0979c485 /gnu/packages/text-editors.scm
parent71cb6dfe10540718eb337e7e2248fc809394894b (diff)
parentc5dc87fee840ad620b01637dc4f9ffa5efc9270c (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm54
1 files changed, 50 insertions, 4 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index f05d1dcd44..c66bea064b 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -8,11 +8,12 @@
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2019, 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Tom Zander <tomz@freedommail.ch>
;;; Copyright © 2020 Mark Meyer <mark@ofosos.org>
;;; Copyright © 2020 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 aecepoglu <aecepoglu@fastmail.fm>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,9 +35,9 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix utils)
+ #:use-module (guix build-system cargo)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
- #:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
#:use-module ((guix licenses) #:prefix license:)
@@ -46,6 +47,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages code)
+ #:use-module (gnu packages crates-io)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
@@ -204,6 +206,50 @@ competitive (as in keystroke count) with Vim.")
(home-page "https://kakoune.org/")
(license license:unlicense)))
+(define-public kak-lsp
+ (package
+ (name "kak-lsp")
+ (version "9.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kak-lsp/kak-lsp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 "1wfv2fy5ga6kc51zka3pak0hq97csm2l11bz74w3n1hrf5q9nnf8")))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-crossbeam-channel" ,rust-crossbeam-channel-0.4)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-daemonize" ,rust-daemonize-0.4)
+ ("rust-dirs" ,rust-dirs-2)
+ ("rust-enum_primitive" ,rust-enum-primitive-0.1)
+ ("rust-glob" ,rust-glob-0.3)
+ ("rust-itertools" ,rust-itertools-0.9)
+ ("rust-lsp-types" ,rust-lsp-types-0.80)
+ ("rust-jsonrpc-core" ,rust-jsonrpc-core-14)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-rand" ,rust-rand-0.7)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-ropey" ,rust-ropey-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde_derive" ,rust-serde-derive-1)
+ ("rust-serde_json" ,rust-serde-json-1)
+ ("rust-slog" ,rust-slog-2)
+ ("rust-slog-scope" ,rust-slog-scope-4)
+ ("rust-sloggers" ,rust-sloggers-1)
+ ("rust-toml" ,rust-toml-0.5)
+ ("rust-url" ,rust-url-2)
+ ("rust-whoami" ,rust-whoami-0.8))))
+ (home-page "https://github.com/kak-lsp/kak-lsp")
+ (synopsis "Language Server Protocol (LSP) client for Kakoune")
+ (description
+ "kak-lsp is a Language Server Protocol client for Kakoune implemented in
+Rust.")
+ (license license:unlicense)))
+
(define-public joe
(package
(name "joe")
@@ -760,14 +806,14 @@ editors.")
(define-public texmacs
(package
(name "texmacs")
- (version "1.99.16")
+ (version "1.99.18")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.texmacs.org/Download/ftp/tmftp/"
"source/TeXmacs-" version "-src.tar.gz"))
(sha256
- (base32 "118sk75k0k9pkyfyx000n2ypab8vm1lz5zxkkdmsi5nwyr3rp56s"))))
+ (base32 "0il3fwgw20421aj90wg8kyhkwk6lbgb3bb2g5qamh5lk90yj725i"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)