summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-05-09 12:10:24 +0100
committerChristopher Baines <mail@cbaines.net>2023-05-10 10:41:03 +0100
commit5e1e67442188ccca8db8c1dd092efbc6fc2c33dc (patch)
tree44a95ea092ee86223f00166d22ff27b83fd8ead8 /gnu/packages/tls.scm
parent8f92dfd9ae7ac491ab7fb4b425799a8c909708a8 (diff)
gnu: guile-gnutls: Update to 3.7.12.
* gnu/packages/tls.scm (guile-gnutls): Update to 3.7.12. [source]: Switch to a tarball, to avoid a circular dependency if guile-gnutls is used in git-download. [arguments]: Remove phase changes for building from Git. [native-inputs]: Remove autoconf and automake as they're now unnecessary. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm44
1 files changed, 12 insertions, 32 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 6d7cff41b0..fc6595cb55 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -319,18 +319,19 @@ required structures.")
;; This package supersedes the Guile bindings that came with GnuTLS until
;; version 3.7.8 included.
(name "guile-gnutls")
- (version "3.7.11")
+ (version "3.7.12")
(home-page "https://gitlab.com/gnutls/guile/")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
+ ;; url-fetch is used here to avoid a circular dependency with
+ ;; git-download, see https://issues.guix.gnu.org/63331
+ (method url-fetch)
+ (uri (string-append
+ "https://gitlab.com/gnutls/guile/uploads/"
+ "3fe12c208bdc6155c5116cf5eac7a2ad"
+ "/guile-gnutls-" version ".tar.gz"))
(sha256
(base32
- "06d7v3i0d9ayp7zqk1rsy4z0wfpq69n0r54f1xrppb9gn7q9iva6"))
- (file-name (git-file-name name version))
- (patches (search-patches "gnutls-cross.patch"))))
+ "0dp3zsbnwgb4q4p8n6i5vnlwq52v5hp8f5c44ngyag89fcaz2fjx"))))
(build-system gnu-build-system)
(arguments
(list
@@ -343,34 +344,13 @@ required structures.")
(string-append "--with-guile-site-ccache-dir="
"$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache")
(string-append "--with-guile-extension-dir="
- "$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/extensions"))
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-more-shebangs
- (lambda _
- (substitute* "autogen.sh"
- (("\\$gnulib_tool \\$gnulib_tool_options")
- "sh $gnulib_tool $gnulib_tool_options"))
- (substitute* "configure.ac"
- (("build-aux/git-version-gen")
- "sh build-aux/git-version-gen"))
- (for-each patch-shebang
- '("autopull.sh" "autogen.sh"))))
- (replace 'bootstrap
- (lambda _
- (invoke "bash" "./bootstrap" "--no-git"))))))
+ "$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/extensions"))))
(native-inputs
- (list autoconf
- automake
- libtool
+ (list libtool
pkg-config
texinfo
gnutls
- guile-3.0 ;XXX: 'guile-snarf' invokes the native 'cpp'
- (gnulib-checkout
- #:version "2022-12-06"
- #:commit "440b528b1d81dd31b2a2e4dde20d5c837c147811"
- #:hash (base32 "15mq43abbnkbamchc9lynrvrd5ql8qacgyx2ph4kkngxf1bz3pqy"))))
+ guile-3.0)) ;XXX: 'guile-snarf' invokes the native 'cpp'
(inputs
(list gnutls
guile-3.0))