summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-31 12:47:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-10-31 14:49:47 +0200
commitbc5155b952ae8bdbc56aded4d8d39768b4e2a7d4 (patch)
tree6b55475d86c522543384dea7d1ab66bba32af63e /gnu/packages/tls.scm
parentdac8d013bd1fc7f57b8ba3582eef6e0e01b23dfd (diff)
parent4e5000114ec01b5e92a87c52f2a10f9ba7a601c8 (diff)
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index b7f3ddd953..908858f6eb 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -180,7 +181,7 @@ in intelligent transportation networks.")
(substitute* "Makefile"
(("test-runtime\\$\\(EXEEXT\\)") ""))
#t)))))
- (home-page "https://p11-glue.freedesktop.org/p11-kit.html")
+ (home-page "https://p11-glue.github.io/p11-glue/p11-kit.html")
(synopsis "PKCS#11 library")
(description
"p11-kit provides a way to load and enumerate PKCS#11 modules. It
@@ -190,6 +191,24 @@ coordinating the use of PKCS#11 by different components or libraries
living in the same process.")
(license license:bsd-3)))
+(define-public p11-kit-next
+ (package
+ (inherit p11-kit)
+ (version "0.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/p11-glue/p11-kit/releases/"
+ "download/" version "/p11-kit-" version ".tar.xz"))
+ (sha256
+ (base32 "11f6saclxsclc1f3lbavzw8kikws4cr3mfd1avly8dgnhh2i9rl1"))))
+ (arguments
+ ;; Use the default certificates so that users such as flatpak find them.
+ ;; See <https://issues.guix.gnu.org/49957>.
+ (substitute-keyword-arguments (package-arguments p11-kit)
+ ((#:configure-flags flags ''())
+ ''("--with-trust-paths=/etc/ssl/certs/ca-certificates.crt"))))))
+
(define-public gnutls
(package
(name "gnutls")