summaryrefslogtreecommitdiff
path: root/gnu/packages/tree-sitter.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2022-11-25 01:21:15 +0000
committerAndrew Tropin <andrew@trop.in>2023-02-09 17:37:13 +0400
commit0cd9bd5dce2b51a6d79a1a1a6fc70bfd787acbc7 (patch)
treeabaf79dbd4d526d70eaa3bdac004d6cf66881085 /gnu/packages/tree-sitter.scm
parent0028204e2610ae399d29c41e0a61863a58fab647 (diff)
gnu: Add tree-sitter-cli.
* gnu/packages/tree-sitter.scm (tree-sitter-cli): New variable. Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages/tree-sitter.scm')
-rw-r--r--gnu/packages/tree-sitter.scm79
1 files changed, 79 insertions, 0 deletions
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index b0d4bb1c38..4a5e082e5b 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -19,7 +19,10 @@
(define-module (gnu packages tree-sitter)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages crates-graphics)
+ #:use-module (gnu packages crates-io)
#:use-module (gnu packages icu4c)
+ #:use-module (guix build-system cargo)
#:use-module (guix build-system gnu)
#:use-module (guix gexp)
#:use-module (guix git-download)
@@ -72,3 +75,79 @@ can be embedded in any application
This package includes the @code{libtree-sitter} runtime library.")
(license license:expat)))
+
+(define-public tree-sitter-cli
+ (package (inherit tree-sitter)
+ (name "tree-sitter-cli")
+ (source (origin
+ (inherit (package-source tree-sitter))
+ (snippet
+ #~(begin
+ ;; Remove the runtime library code and dynamically link to
+ ;; it instead.
+ (delete-file-recursively "lib/src")
+ (delete-file "lib/binding_rust/build.rs")
+ (with-output-to-file "lib/binding_rust/build.rs"
+ (lambda _
+ (format #t "fn main() {~@
+ println!(\"cargo:rustc-link-lib=tree-sitter\");~@
+ }~%")))))))
+ (build-system cargo-build-system)
+ (inputs (list tree-sitter))
+ (arguments
+ (list
+ ;; Running test requires downloading fixtures, see the
+ ;; script/fetch-fixtures script, which fetches grammars. Maybe it make
+ ;; sence to run tests in the grammar's packages?
+ #:tests? #f
+ ;; We're only packaging the CLI program so we do not need to install
+ ;; sources.
+ #:install-source? #f
+ #:cargo-inputs
+ `(("rust-ansi-term" ,rust-ansi-term-0.12)
+ ("rust-anyhow" ,rust-anyhow-1)
+ ("rust-atty" ,rust-atty-0.2)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-difference" ,rust-difference-2)
+ ("rust-dirs" ,rust-dirs-3)
+ ("rust-html-escape" ,rust-html-escape-0.2)
+ ("rust-libloading" ,rust-libloading-0.7)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-rustc-hash" ,rust-rustc-hash-1)
+ ("rust-semver" ,rust-semver-1)
+ ("rust-smallbitvec" ,rust-smallbitvec-2)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-tiny-http" ,rust-tiny-http-0.8)
+ ("rust-toml" ,rust-toml-0.5)
+ ("rust-walkdir" ,rust-walkdir-2)
+ ("rust-webbrowser" ,rust-webbrowser-0.5)
+ ("rust-which" ,rust-which-4))
+ #:cargo-development-inputs
+ `(("rust-pretty-assertions" ,rust-pretty-assertions-0.7))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'delete-cargo-lock
+ (lambda _
+ (delete-file "Cargo.lock")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append #$output "/bin")))
+ (mkdir-p bin)
+ (install-file "target/release/tree-sitter" bin)))))))
+ (description "Tree-sitter is a parser generator tool and an incremental
+parsing library. It can build a concrete syntax tree for a source file and
+efficiently update the syntax tree as the source file is edited.
+
+Tree-sitter aims to be:
+
+@enumerate
+@item General enough to parse any programming language.
+@item Fast enough to parse on every keystroke in a text editor.
+@item Robust enough to provide useful results even in the presence of syntax
+errors.
+@item Dependency-free so that the runtime library (which is written in pure C)
+can be embedded in any application.
+@end enumerate
+
+This package includes the @command{tree-sitter} command-line tool.")
+ (license license:expat)))