summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-02-26 23:20:43 +0100
committerLudovic Courtès <ludo@gnu.org>2024-02-26 23:41:36 +0100
commit2a7f7af87cfe71b0b6591b599b75cdaa51e301d7 (patch)
tree0bace4bfe0e238c8ddb9041f01315365117fa6f8 /gnu/packages/version-control.scm
parentb6604de2262be4f8a765a7fb3a82afedb48575b0 (diff)
gnu: libgit2: Set ‘GITTEST_FLAKY_STAT’ when running tests on GNU/Hurd.
* gnu/packages/version-control.scm (libgit2)[arguments]: Install ‘pre-check’ phase when ‘target-hurd?’ returns true. Change-Id: I664d4aa2a0ad76a10a47ae7bc3c5912756972b46
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index af237ab4ee..ba2f1d6fad 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -911,8 +911,10 @@ other git-like projects such as @code{libgit2}.")
'()))
#:phases
(modify-phases %standard-phases
- ,@(if (target-arm32?)
+ ,@(if (or (target-arm32?) (target-hurd?))
;; Some tests are flaky on armhf.
+ ;; On GNU/Hurd, the 'diff/workdir' test in libgit2 1.7.1 fails
+ ;; while comparing st.st_size to zero.
'((add-before 'check 'pre-check
(lambda _
(setenv "GITTEST_FLAKY_STAT" "true"))))