summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-08 21:12:52 +0200
committerMarius Bakke <marius@gnu.org>2022-09-08 21:12:52 +0200
commit884548b476f2ee27c01cb0c9ad93c0cf9d33fa5e (patch)
tree20650b3917b1292470ecc4ded13fbb04e5dbfa6d /gnu/packages/version-control.scm
parent0e305798454c558ab6e722cf66ba351c326a1a8d (diff)
parentfa894b3f4db835bd0bb52b32c7ec412e72b7e03a (diff)
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm31
1 files changed, 15 insertions, 16 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 54ad585c75..813037a421 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -221,14 +221,14 @@ Python 3.3 and later, rather than on Python 2.")
(define-public git
(package
(name "git")
- (version "2.37.2")
+ (version "2.37.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "00xhdm086bxm4v2p8m7ra7vf9kwdppw4l2n3vakfff253j19qg8w"))))
+ "0yp8hdj0w18jhmmdflzz74z418cw95i08pc22yycyn8nyvbl2il1"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -248,7 +248,7 @@ Python 3.3 and later, rather than on Python 2.")
version ".tar.xz"))
(sha256
(base32
- "1zhn91fzyyz890a5hm0bvs0vnhy8c81q1fhsk2gfwbbh73z161nz"))))
+ "053lj9wy8y2yr5jzpb0af4w50gz3ckhgc15wqx7is4z6k9a76lww"))))
;; For subtree documentation.
("asciidoc" ,asciidoc)
("docbook2x" ,docbook2x)
@@ -1571,17 +1571,15 @@ also walk each side of a merge and test those changes individually.")
(coreutils (assoc-ref inputs "coreutils"))
(findutils (assoc-ref inputs "findutils"))
(git (assoc-ref inputs "git")))
- (wrap-program (string-append out "/bin/gitolite")
- `("PATH" ":" prefix
- ,(map (lambda (dir)
- (string-append dir "/bin"))
- (list out coreutils findutils git))))))))))
+ (for-each (lambda (file-name)
+ (wrap-program (string-append out file-name)
+ `("PATH" ":" prefix
+ ,(map (lambda (dir)
+ (string-append dir "/bin"))
+ (list out coreutils findutils git)))))
+ '("/bin/gitolite" "/bin/gitolite-shell"))))))))
(inputs
- (list bash-minimal perl coreutils findutils inetutils))
- ;; git and openssh are propagated because trying to patch the source via
- ;; regexp matching is too brittle and prone to false positives.
- (propagated-inputs
- (list git openssh))
+ (list bash-minimal coreutils findutils git inetutils openssh perl))
(home-page "https://gitolite.com")
(synopsis "Git access control layer")
(description
@@ -2847,14 +2845,14 @@ specific files and directories.")
(define-public src
(package
(name "src")
- (version "1.18")
+ (version "1.29")
(source (origin
(method url-fetch)
(uri (string-append
"http://www.catb.org/~esr/src/src-" version ".tar.gz"))
(sha256
(base32
- "0n0skhvya8w2az45h2gsafxy8m2mvqas64nrgxifcmrzfv0rf26c"))))
+ "0ha287gc95vz6bdvn42pi3qibc56h1w5dshsvjvdn2zd283amksd"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags
@@ -2880,7 +2878,8 @@ specific files and directories.")
;; For testing.
(list git perl))
(inputs
- `(("python" ,python-wrapper)
+ `(("cssc" ,cssc)
+ ("python" ,python-wrapper)
("rcs" ,rcs)))
(synopsis "Simple revision control")
(home-page "http://www.catb.org/~esr/src/")