summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2023-01-21 16:56:46 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-21 15:05:35 -0500
commitba17b160ed7d09ef58183c22b6f1b10ee7ba926d (patch)
treeeb6884342620f5e030da4ac9ff065e8a99def049 /gnu/packages/version-control.scm
parent900d33527c9286a811f064d4bb8f4a9b18d1db0b (diff)
gnu: Remove reposurgeon.
This package is broken since 2018 and an update requires Go modules. * gnu/packages/version-control.scm (reposurgeon): Delete variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm76
1 files changed, 0 insertions, 76 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index ff2fccef0c..78a89cfd5b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2399,82 +2399,6 @@ as possible. Resolution of contention for source files, a major headache for
any project with more than one developer, is one of Aegis's major functions.")
(license license:gpl3+)))
-(define-public reposurgeon
- (package
- (name "reposurgeon")
- (version "3.43")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.catb.org/~esr/" name "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1af0z14wcm4bk5a9ysinbwq2fp3lf5f7i8mvwh7286hr3fnagcaz"))
- (patches (search-patches
- "reposurgeon-add-missing-docbook-files.patch"))))
- (build-system gnu-build-system)
- (arguments
- `(#:make-flags
- (list "ECHO=echo"
- (string-append "target=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-inputs
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((tzdata (assoc-ref inputs "tzdata")))
- (substitute* "reposurgeon"
- (("/usr/share/zoneinfo")
- (string-append tzdata "/share/zoneinfo")))
- (substitute* "test/svn-to-svn"
- (("/bin/echo") "echo"))
- #t)))
- (delete 'configure) ; no configure script
- (add-before 'build 'fix-docbook
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* (find-files "." "\\.xml$")
- (("docbook/docbookx.dtd")
- (string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/docbookx.dtd")))
- #t))
- (add-before 'check 'set-up-test-environment
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((tzdata (assoc-ref inputs "tzdata")))
- (setenv "TZDIR" (string-append tzdata "/share/zoneinfo"))
- #t)))
- (add-after 'install 'install-emacs-data
- (lambda* (#:key outputs #:allow-other-keys)
- (install-file "reposurgeon-mode.el"
- (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp"))
- #t)))))
- (inputs
- `(("python" ,python-wrapper)
- ("tzdata" ,tzdata)))
- (native-inputs
- (list ;; For building documentation.
- asciidoc
- docbook-xml
- docbook-xsl
- libxml2
- xmlto
- ;; For tests.
- cvs
- git
- mercurial
- subversion))
- (home-page "http://www.catb.org/~esr/reposurgeon/")
- (synopsis "Edit version-control repository history")
- (description "Reposurgeon enables risky operations that version-control
-systems don't want to let you do, such as editing past comments and metadata
-and removing commits. It works with any version control system that can
-export and import Git fast-import streams, including Git, Mercurial, Fossil,
-Bazaar, CVS, RCS, and Src. It can also read Subversion dump files directly
-and can thus be used to script production of very high-quality conversions
-from Subversion to any supported Distributed Version Control System (DVCS).")
- ;; Most files are distributed under bsd-2, except 'repocutter' which is
- ;; under bsd-3.
- (license (list license:bsd-2 license:bsd-3))))
-
(define-public tig
(package
(name "tig")