summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-07-17 23:33:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-07-17 23:33:55 +0300
commit0f646fc79a06c9857f5f28d5a1eebd09f2d17310 (patch)
tree2afe7b35579617c78ba6b062936b637a3ea52ca1 /gnu/packages/video.scm
parentf4ac75205825a4bb3ba986f31350b39222d71670 (diff)
gnu: libmpeg3: Fix building on many architectures.
* gnu/packages/video.scm (libmpeg3)[arguments]: Add a custom phase to set the CFLAGS based on the Makefile. Remove trailing #t from phases.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 559048dd9e..fe7f153244 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -691,13 +691,17 @@ touchscreen devices and the ability to apply filters to their input events.")
(("\\(A52DIR\\)/include")
"(A52DIR)/include/a52dec")
(("LIBS = " match)
- (string-append match "-la52 ")))
- #t))
+ (string-append match "-la52 ")))))
+ (add-after 'unpack 'preseed-cflags
+ (lambda _
+ (setenv "CFLAGS"
+ (string-append "-D_FILE_OFFSET_BITS=64 "
+ "-D_LARGEFILE_SOURCE "
+ "-D_LARGEFILE64_SOURCE"))))
(add-before 'install 'create-destination-directory
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (string-append (assoc-ref outputs "out"))))
- (mkdir-p (string-append out "/bin"))
- #t))))))
+ (mkdir-p (string-append out "/bin"))))))))
(native-inputs
(list nasm))
(inputs