summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:02 +0200
commit313a442f7bd4bb3054d271fbda4527a0ea943788 (patch)
tree3b272bd75880a8c7ed2dca2c0f3f4928703dc815 /gnu/packages/video.scm
parent5f4cd5243c8a409f63a443d093b5a554ad7d3c92 (diff)
gnu: get-iplayer: Update to 3.30.
* gnu/packages/video.scm (get-iplayer): Update to 3.30. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ac7329d4b7..af658ea8d7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -5387,7 +5387,7 @@ brightness, contrast, and frame rate.")
(define-public get-iplayer
(package
(name "get-iplayer")
- (version "3.27")
+ (version "3.30")
(source
(origin
(method git-fetch)
@@ -5396,7 +5396,7 @@ brightness, contrast, and frame rate.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "077y31gg020wjpx5pcivqgkqawcjxh5kjnvq97x2gd7i3wwc30qi"))))
+ (base32 "1kzsdq1mhm5h83bbdbhh3jhpfvq4f13ly22mfd6vvmhj8mq084pi"))))
(build-system perl-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -5411,8 +5411,7 @@ brightness, contrast, and frame rate.")
(man (string-append out "/share/man/man1")))
(install-file "get_iplayer" bin)
(install-file "get_iplayer.cgi" bin)
- (install-file "get_iplayer.1" man))
- #t))
+ (install-file "get_iplayer.1" man))))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -5423,8 +5422,7 @@ brightness, contrast, and frame rate.")
prefix (,(string-append perllib ":" (getenv "PERL5LIB")))))
(wrap-program (string-append out "/bin/get_iplayer.cgi")
`("PERL5LIB" ":"
- prefix (,(string-append perllib ":" (getenv "PERL5LIB")))))
- #t))))))
+ prefix (,(string-append perllib ":" (getenv "PERL5LIB")))))))))))
(inputs
(list perl-mojolicious perl-lwp-protocol-https perl-xml-libxml))
(home-page "https://github.com/get-iplayer/get_iplayer")