summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-23 18:42:17 +0200
committerMarius Bakke <marius@gnu.org>2022-06-23 19:55:42 +0200
commit87793b349fe8dcca58c8b1964f3e78f35a4b1613 (patch)
treefd2819ae3b771740ef7f49de4851f7dedad427be /gnu/packages/video.scm
parenta49c829a0500ab5606021c60eb1f6412566ff4ca (diff)
gnu: libva: Use G-expressions.
* gnu/packages/video.scm (libva)[arguments]: Use G-expressions.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm35
1 files changed, 16 insertions, 19 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 9363b6de87..a82b1b8889 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1490,27 +1490,24 @@ quality and performance.")
mesa
wayland))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before
- 'build 'fix-dlopen-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
+ (list
+ ;; Most drivers are in mesa's $prefix/lib/dri, so use that. (Can be
+ ;; overridden at run-time via LIBVA_DRIVERS_PATH.)
+ #:configure-flags
+ #~(list (string-append "--with-drivers-path="
+ (search-input-directory %build-inputs "lib/dri")))
+ ;; However, we can't write to mesa's store directory, so override the
+ ;; following make variable to install the dummy driver to libva's
+ ;; $prefix/lib/dri directory.
+ #:make-flags
+ #~(list (string-append "dummy_drv_video_ladir=" #$output "/lib/dri"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'fix-dlopen-paths
+ (lambda _
(substitute* "va/drm/va_drm_auth_x11.c"
(("\"libva-x11\\.so\\.%d\"")
- (string-append "\"" out "/lib/libva-x11.so.%d\"")))
- #t))))
- ;; Most drivers are in mesa's $prefix/lib/dri, so use that. (Can be
- ;; overridden at run-time via LIBVA_DRIVERS_PATH.)
- #:configure-flags
- (list (string-append "--with-drivers-path="
- (assoc-ref %build-inputs "mesa") "/lib/dri"))
- ;; However, we can't write to mesa's store directory, so override the
- ;; following make variable to install the dummy driver to libva's
- ;; $prefix/lib/dri directory.
- #:make-flags
- (list (string-append "dummy_drv_video_ladir="
- (assoc-ref %outputs "out") "/lib/dri"))))
+ (string-append "\"" #$output "/lib/libva-x11.so.%d\""))))))))
(home-page "https://www.freedesktop.org/wiki/Software/vaapi/")
(synopsis "Video acceleration library")
(description "The main motivation for VA-API (Video Acceleration API) is