summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-12-03 11:20:45 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-12-15 16:55:51 +0100
commitf19d49e69cce1a962cdd77b3cb7e1dcbe0d22240 (patch)
tree7fcff885ca90f8480d0c96f21eeb25e676d4604b /gnu/packages/video.scm
parent4f94156452f8c9292c802686f099c2830a205312 (diff)
gnu: Add orf-dl.
* gnu/packages/video.scm (orf-dl): New variable.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index a15c86ee07..e32186f5ce 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -167,6 +167,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages perl-web)
+ #:use-module (gnu packages php)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
@@ -2444,6 +2445,38 @@ To load this plugin, specify the following option when starting mpv:
(base32
"1x12f2bd4jqd532rnixmwvcx8d29yxiacpcxqqh86qczc49la8gm"))))))
+(define-public orf-dl
+ (let ((commit "2dbbe7ef4e0efe0f3c1d59c503108e22d9065999")
+ (revision "1"))
+ (package
+ (name "orf-dl")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tpoechtrager/orf_dl")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1w413miy01cm7rzb5c6wwfdnc2sqv87cvxwikafgrkswpimvdjsk"))))
+ (build-system copy-build-system)
+ (arguments
+ (list #:install-plan #~`(("orf_dl.php" "bin/orf-dl"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "orf_dl.php"
+ (("ffmpeg")
+ (search-input-file inputs "bin/ffmpeg"))))))))
+ (inputs (list php ffmpeg))
+ (home-page "https://github.com/tpoechtrager/orf_dl")
+ (synopsis "Download videos from tvthek.orf.at")
+ (description "This package provides a PHP-based command line application
+to download videos from Austria's national television broadcaster.")
+ (license license:gpl2+))))
+
(define-public youtube-dl
(package
(name "youtube-dl")