summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2022-07-02 15:10:30 -0400
committerChristopher Baines <mail@cbaines.net>2022-07-08 00:16:14 +0100
commitf53e14be33a6b2476a36dee29490db50ed02467f (patch)
treeca16463402cc55048e870ef59e3bdc99117f0028 /gnu/packages/video.scm
parent07986d0fade3bf3bc207c026821b87ec9764f9b0 (diff)
gnu: vlc: Remove input labels.
* gnu/packages/video.scm (vlc)[native-inputs]: Remove input labels. [inputs]: Remove input labels and re-sort. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm153
1 files changed, 75 insertions, 78 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7151e903d1..5bd6eba93a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1902,86 +1902,83 @@ videoformats depend on the configuration flags of ffmpeg.")
"0cs1vnv91mg7p6253v6wms3zlz91xzphpwaw14dmrd2gibc64nlc"))))
(build-system gnu-build-system)
(native-inputs
- `(("flex" ,flex)
- ("bison" ,bison)
- ("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)))
+ (list flex bison gettext-minimal pkg-config))
;; FIXME: Add optional inputs once available.
(inputs
- `(("alsa-lib" ,alsa-lib)
- ("avahi" ,avahi)
- ("dav1d" ,dav1d)
- ("dbus" ,dbus)
- ("eudev" ,eudev)
- ("flac" ,flac)
- ("ffmpeg" ,ffmpeg)
- ("fontconfig" ,fontconfig)
- ("freetype" ,freetype)
- ("fribidi" ,fribidi)
- ("gnutls" ,gnutls)
- ("liba52" ,liba52)
- ("libarchive" ,libarchive)
- ("libass" ,libass)
- ("libavc1394" ,libavc1394)
- ("libbluray" ,libbluray)
- ("libcaca" ,libcaca)
- ("libcddb" ,libcddb)
- ("libdca" ,libdca)
- ("libdvbpsi" ,libdvbpsi)
- ("libdvdnav" ,libdvdnav)
- ("libdvdread" ,libdvdread)
- ("libebml" ,libebml)
- ("libgcrypt" ,libgcrypt)
- ("libidn" ,libidn)
- ("libkate" ,libkate)
- ("libmad" ,libmad)
- ("libmatroska" ,libmatroska)
- ("libmicrodns" ,libmicrodns)
- ("libmodplug" ,libmodplug)
- ("libmpeg2" ,libmpeg2)
- ("libogg" ,libogg)
- ("libpng" ,libpng)
- ("libraw1394" ,libraw1394)
- ("librsvg" ,(librsvg-for-system))
- ("libsamplerate" ,libsamplerate)
- ("libsecret" ,libsecret)
- ("libssh2" ,libssh2)
- ("libupnp" ,libupnp)
- ("libva" ,libva)
- ("libvdpau" ,libvdpau)
- ("libvorbis" ,libvorbis)
- ("libvpx" ,libvpx)
- ("libtheora" ,libtheora)
- ("libx264" ,libx264)
- ("libxext" ,libxext)
- ("libxi" ,libxi)
- ("libxinerama" ,libxinerama)
- ("libxml2" ,libxml2)
- ("libxpm" ,libxpm)
- ("livemedia-utils" ,livemedia-utils)
- ("lua" ,lua-5.2)
- ("mesa" ,mesa)
- ("opus" ,opus)
- ("perl" ,perl)
- ("pulseaudio" ,pulseaudio)
- ("protobuf" ,protobuf)
- ("python" ,python-wrapper)
- ("qtbase" ,qtbase-5)
- ("qtsvg" ,qtsvg)
- ("qtx11extras" ,qtx11extras)
- ("samba" ,samba)
- ("sdl" ,sdl)
- ("sdl-image" ,sdl-image)
- ("speex" ,speex)
- ("speexdsp" ,speexdsp)
- ("srt" ,srt)
- ("taglib" ,taglib)
- ("twolame" ,twolame)
- ("unzip" ,unzip)
- ("wayland" ,wayland)
- ("wayland-protocols" ,wayland-protocols)
- ("x265" ,x265)
- ("xcb-util-keysyms" ,xcb-util-keysyms)))
+ (list alsa-lib
+ avahi
+ dav1d
+ dbus
+ eudev
+ ffmpeg
+ flac
+ fontconfig
+ freetype
+ fribidi
+ gnutls
+ liba52
+ libarchive
+ libass
+ libavc1394
+ libbluray
+ libcaca
+ libcddb
+ libdca
+ libdvbpsi
+ libdvdnav
+ libdvdread
+ libebml
+ libgcrypt
+ libidn
+ libkate
+ libmad
+ libmatroska
+ libmicrodns
+ libmodplug
+ libmpeg2
+ libogg
+ libpng
+ libraw1394
+ (librsvg-for-system)
+ libsamplerate
+ libsecret
+ libssh2
+ libtheora
+ libupnp
+ libva
+ libvdpau
+ libvorbis
+ libvpx
+ libx264
+ libxext
+ libxi
+ libxinerama
+ libxml2
+ libxpm
+ livemedia-utils
+ lua-5.2
+ mesa
+ opus
+ perl
+ protobuf
+ pulseaudio
+ python-wrapper
+ qtbase-5
+ qtsvg
+ qtx11extras
+ samba
+ sdl
+ sdl-image
+ speex
+ speexdsp
+ srt
+ taglib
+ twolame
+ unzip
+ wayland
+ wayland-protocols
+ x265
+ xcb-util-keysyms))
(arguments
`(#:configure-flags
`("BUILDCC=gcc"