summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2021-04-23 16:05:06 -0400
committerEfraim Flashner <efraim@flashner.co.il>2021-06-21 17:23:36 +0300
commit6acc04eca75fccd517e33b9aa7f5a02a300ec74a (patch)
tree12fd8d399faa14f99918e3b20aff1456a417d497 /gnu/packages/vim.scm
parent5506b841d18fa415321c22b7e2b7eec9f6ce50d9 (diff)
gnu: Add eovim.
* gnu/packages/vim (eovim): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm45
1 files changed, 44 insertions, 1 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 238c25d486..7a37162116 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2019 HiPhish <hiphish@posteo.de>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019, 2020 Jakub Kądziołka <kuba@kadziolka.net>
-;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020, 2021 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Tissevert <tissevert+guix@marvid.fr>
;;;
@@ -43,6 +43,7 @@
#:use-module (gnu packages attr)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages enlightenment)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gettext)
@@ -746,6 +747,48 @@ refactor Vim in order to:
;; except for parts that were contributed under the Vim license.
(license (list license:asl2.0 license:vim))))
+(define-public eovim
+ (package
+ (name "eovim")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeanguyomarch/eovim/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06b7crmz3wvvq15ncl0jk20s8j1pmna2jin0k5y5n5qxpafbgp3k"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #false ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'reference-nvim
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((nvim (string-append (assoc-ref inputs "neovim")
+ "/bin/nvim")))
+ ;; This substitution should change one line, and replaces the default
+ ;; value in the struct of options with an absolute store reference.
+ (substitute* "../source/src/main.c"
+ (("(^[[:blank:]]+\\.nvim = \")nvim" _ start)
+ (string-append start nvim))))))
+ (add-before 'build 'set-home
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("efl" ,efl)
+ ("msgpack" ,msgpack)
+ ("neovim" ,neovim)))
+ (home-page "https://github.com/jeanguyomarch/eovim/")
+ (synopsis "EFL GUI for Neovim")
+ (description "Graphical Neovim interface based on the @acronym{EFL, Enlightenment
+Foundation Libraries} toolkit. Its features include customizable appearance
+and support for fonts with ligatures.")
+ (license license:expat)))
+
(define-public vifm
(package
(name "vifm")