summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-01 14:59:07 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-02 10:40:35 -0500
commit0a74d78d439ad1234052c6ed9c409c7236e6144f (patch)
tree0fb742f9a40360eca160b9719720b594be0bdf14 /gnu/packages/web.scm
parentc90361b32265b9332d7633e3df5b944486ae63a3 (diff)
gnu: Add Catalyst-Plugin-AccessLog.
* gnu/packages/web.scm (perl-catalyst-plugin-accesslog): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 32bc68fe4f..0a69891824 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -723,6 +723,32 @@ when the dispatch type is first seen in your application.")
Models.")
(license (package-license perl))))
+(define-public perl-catalyst-plugin-accesslog
+ (package
+ (name "perl-catalyst-plugin-accesslog")
+ (version "1.05")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/A/AR/ARODLAND/"
+ "Catalyst-Plugin-AccessLog-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hqvckaw91q5yc25a33bp0d4qqxlgkp7rxlvi8n8svxd1406r55s"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-catalyst-runtime" ,perl-catalyst-runtime)
+ ("perl-datetime" ,perl-datetime)
+ ("perl-moose" ,perl-moose)
+ ("perl-namespace-autoclean" ,perl-namespace-autoclean)))
+ (arguments `(#:tests? #f)) ;Unexpected http responses
+ (home-page "http://search.cpan.org/dist/Catalyst-Plugin-AccessLog")
+ (synopsis "Request logging from within Catalyst")
+ (description "This Catalyst plugin enables you to create \"access logs\"
+from within a Catalyst application instead of requiring a webserver to do it
+for you. It will work even with Catalyst debug logging turned off.")
+ (license (package-license perl))))
+
(define-public perl-catalyst-plugin-authentication
(package
(name "perl-catalyst-plugin-authentication")