summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-10-23 10:05:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-24 00:06:20 +0200
commit0a9bdd95835b1f8a39de44f1c230504234b0fb82 (patch)
treec9007518a61c661c2b7ae4fef8d6fb00c77dc440 /gnu/packages/web.scm
parentefc8f7d03d8c5857467fa14e85d5cdc267af58a7 (diff)
gnu: Add tidyp.
* gnu/packages/web.scm (tidyp): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 686659ad78..2791eb05cc 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5931,3 +5931,29 @@ container.")))
("http-test" ,java-eclipse-jetty-http-test-classes-9.2)
("server" ,java-eclipse-jetty-server-9.2)
,@(package-inputs java-eclipse-jetty-util-9.2)))))
+
+(define-public tidyp
+ (package
+ (name "tidyp")
+ (version "1.04")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/downloads/petdance/tidyp/tidyp-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0f5ky0ih4vap9c6j312jn73vn8m2bj69pl2yd3a5nmv35k9zmc10"))))
+ (build-system gnu-build-system)
+ ;; ./test-thing.sh tries to run ./testall.sh, which is not included.
+ (arguments `(#:tests? #f))
+ (home-page "http://www.tidyp.com/")
+ (synopsis "Validate HTML")
+ (description "Tidyp is a program that can validate your HTML, as well as
+modify it to be more clean and standard. tidyp does not validate HTML 5.
+
+libtidyp is the library on which the program is based. It can be used by any
+other program that can interface to it. The Perl module @code{HTML::Tidy} is
+based on this library, allowing Perl programmers to easily validate HTML.")
+ ;; See htmldoc/license.html
+ (license l:bsd-3)))