summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-10 15:46:50 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-11 15:48:06 -0500
commit2b63ebc1fea2bacca53c40e2805f4daa48d1f4bc (patch)
tree4e98ba37fd1a17adef0353bd048a88dfe4c4cd26 /gnu/packages/web.scm
parentc8a316a3b7c2ebeb10e4a9dc4a732b7ae19aafa0 (diff)
gnu: Add IO-Socket-IP.
* gnu/packages/web.scm (perl-io-socket-ip): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f8eda6e4f1..18a193c539 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -780,6 +780,25 @@ automatically determining its encoding. It uses the HTML5 encoding sniffing
algorithm specified in section 8.2.2.1 of the draft standard.")
(home-page "http://search.cpan.org/~cjm/IO-HTML/")))
+(define-public perl-io-socket-ip
+ (package
+ (name "perl-io-socket-ip")
+ (version "0.36")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/P/PE/PEVANS/"
+ "IO-Socket-IP-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ky20hmln6waipzqikizyw04vpszf70fgpshz7ib8zv8480ri456"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/IO-Socket-IP")
+ (synopsis "Family-neutral IP socket supporting both IPv4 and IPv6")
+ (description "This module provides a protocol-independent way to use IPv4
+and IPv6 sockets, intended as a replacement for IO::Socket::INET.")
+ (license (package-license perl))))
+
(define-public perl-io-socket-ssl
(package
(name "perl-io-socket-ssl")