summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2017-11-25 11:12:08 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2017-11-28 20:23:46 +0300
commit2cdf78df2d3d5d88c7e6908754233cf37cce1e61 (patch)
treeb3a307b058204a2d3b60b54db77afe5166bb80b8 /gnu/packages/web.scm
parent25fa22a99b31c91dba398935ef9457a7664d8156 (diff)
gnu: python-internetarchive: Enable tests.
* gnu/packages/web.scm (python-internetarchive): Enable tests.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 9ea7c14dd7..33689042ab 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5172,21 +5172,20 @@ command-line arguments or read from stdin.")
"0sdbb2ag6vmybi8zmbjszi492a587giaaqxyy1p6gy03cb8mc512"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; 11 tests of 105 fail to mock "requests".
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(delete 'check)
(add-after 'install 'check
- (lambda* (#:key inputs outputs target (tests? (not target)) #:allow-other-keys)
- (if tests?
- (begin
- (add-installed-pythonpath inputs outputs)
- (setenv "PATH" (string-append (assoc-ref outputs "out") "/bin"
- ":" (getenv "PATH")))
- (zero? (system* "py.test")))
- (begin
- (format #t "test suite not run~%")
- #t)))))))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (setenv "PATH" (string-append (assoc-ref outputs "out") "/bin"
+ ":" (getenv "PATH")))
+ (zero? (system* "py.test" "-v" "-k"
+ (string-append
+ ;; These tests attempt to make a connection to
+ ;; an external web service.
+ "not test_get_item_with_kwargs"
+ " and not test_ia"))))))))
(propagated-inputs
`(("python-requests" ,python-requests)
("python-jsonpatch" ,python-jsonpatch-0.4)