summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-26 02:41:18 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 12:06:30 +0200
commit3ab568573e220def0bcfaff56b289db166fdb110 (patch)
tree91b9ee0d1b05296a766924c3521aeff2fefb2304 /gnu/packages/web.scm
parent1d3aedf18c38203135de9c6621f3660f458dad3f (diff)
gnu: nghttp2: Remove input labels.
* gnu/packages/web.scm (nghttp2)[inputs]: Remove labels. [arguments]: Use SEARCH-INPUT-DIRECTORY.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm26
1 files changed, 12 insertions, 14 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index edffcd6711..6b34d5aa7a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7505,16 +7505,15 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
cunit python tzdata-for-tests))
(inputs
;; Required to build the tools (i.e. without ‘--enable-lib-only’).
- `(("c-ares" ,c-ares)
- ("jansson" ,jansson) ; for HPACK tools
- ,@(if (hurd-target?) '()
- `(("jemalloc" ,jemalloc))) ; fight nghttpd{,x} heap fragmentation
- ("libev" ,libev)
- ("libxml2" ,libxml2) ; for ‘nghttp -a’
- ("openssl" ,openssl)
- ,@(if (hurd-target?)
- `(("openssl-static" ,openssl "static"))
- '())))
+ (append
+ (if (hurd-target?)
+ `(,openssl "static")
+ (list jemalloc)) ; fight nghttpd{,x} heap fragmentation
+ (list c-ares
+ jansson ; for HPACK tools
+ libev
+ libxml2 ; for ‘nghttp -a’
+ openssl)))
(arguments
`(#:configure-flags
(list (string-append "--libdir=" (assoc-ref %outputs "lib") "/lib")
@@ -7539,10 +7538,9 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
#t))
(add-before 'check 'set-timezone-directory
(lambda* (#:key inputs native-inputs #:allow-other-keys)
- (setenv "TZDIR" (string-append
- (assoc-ref (or native-inputs inputs) "tzdata")
- "/share/zoneinfo"))
- #t)))))
+ (setenv "TZDIR" (search-input-directory
+ (or native-inputs inputs)
+ "share/zoneinfo")))))))
(home-page "https://nghttp2.org/")
(synopsis "HTTP/2 protocol client, proxy, server, and library")
(description