summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-01 12:28:57 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-02 10:40:34 -0500
commit9473af1d2c5867f6060594c863b8a6e22ccd77a4 (patch)
tree638ca4204e9760de470aa601615eb2620242b068 /gnu/packages/web.scm
parent488c34ece412c2a75a7655e8dffa2842c38f96b8 (diff)
gnu: Add Catalyst-DispatchType-Regex.
* gnu/packages/web.scm (perl-catalyst-dispatchtype-regex): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index cbf3cb3465..32bc68fe4f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -648,6 +648,36 @@ extension for Catalyst; and requirements for a variety of development-related
modules.")
(license (package-license perl))))
+(define-public perl-catalyst-dispatchtype-regex
+ (package
+ (name "perl-catalyst-dispatchtype-regex")
+ (version "5.90035")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MG/MGRIMES/"
+ "Catalyst-DispatchType-Regex-" version ".tar.gz"))
+ (sha256
+ (base32
+ "06jq1lmpq88rmp9zik5gqczg234xac0hiyc3l698iif7zsgcyb80"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build) ;needs Module::Build >= 0.4004
+ ("perl-namespace-autoclean" ,perl-namespace-autoclean)
+ ("perl-catalyst-runtime" ,perl-catalyst-runtime)))
+ (propagated-inputs
+ `(("perl-moose" ,perl-moose)
+ ("perl-text-simpletable" ,perl-text-simpletable)))
+ (home-page "http://search.cpan.org/dist/Catalyst-DispatchType-Regex")
+ (synopsis "Regex DispatchType for Catalyst")
+ (description "Dispatch type managing path-matching behaviour using
+regexes. Regex dispatch types have been deprecated and removed from Catalyst
+core. It is recommend that you use Chained methods or other techniques
+instead. As part of the refactoring, the dispatch priority of Regex vs Regexp
+vs LocalRegex vs LocalRegexp may have changed. Priority is now influenced by
+when the dispatch type is first seen in your application.")
+ (license (package-license perl))))
+
(define-public perl-catalyst-model-dbic-schema
(package
(name "perl-catalyst-model-dbic-schema")