summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-04-05 12:31:54 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-04-05 13:06:24 -0400
commita71c315bc2e5b4ab6332095e9fdc2617191abb5e (patch)
treee2f7c0acf51b76eedaf6a06681dc1408f195cbba /gnu/packages/web.scm
parente16fde1447840ffb1cafd505b10c4296da4d44e3 (diff)
gnu: nginx: Use modify-phases syntax.
* gnu/packages/web.scm (nginx): Use modify-phases syntax.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm62
1 files changed, 30 insertions, 32 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 42d58c8989..031bbcafe4 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -108,38 +108,36 @@ and its related documentation.")
(arguments
`(#:tests? #f ; no test target
#:phases
- (alist-cons-before
- 'configure 'patch-/bin/sh
- (lambda _
- (substitute* "auto/feature"
- (("/bin/sh") (which "bash"))))
- (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((flags
- (list (string-append "--prefix=" (assoc-ref outputs "out"))
- "--with-http_ssl_module"
- "--with-pcre-jit"
- "--with-ipv6"
- "--with-debug"
- ;; Even when not cross-building, we pass the
- ;; --crossbuild option to avoid customizing for the
- ;; kernel version on the build machine.
- ,(let ((system "Linux") ; uname -s
- (release "2.6.32") ; uname -r
- ;; uname -m
- (machine (match (or (%current-target-system)
- (%current-system))
- ("x86_64-linux" "x86_64")
- ("i686-linux" "i686")
- ("mips64el-linux" "mips64"))))
- (string-append "--crossbuild="
- system ":" release ":" machine)))))
- (setenv "CC" "gcc")
- (format #t "environment variable `CC' set to `gcc'~%")
- (format #t "configure flags: ~s~%" flags)
- (zero? (apply system* "./configure" flags))))
- %standard-phases))))
+ (modify-phases %standard-phases
+ (add-before configure patch-/bin/sh
+ (lambda _
+ (substitute* "auto/feature"
+ (("/bin/sh") (which "bash")))))
+ (replace configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((flags
+ (list (string-append "--prefix=" (assoc-ref outputs "out"))
+ "--with-http_ssl_module"
+ "--with-pcre-jit"
+ "--with-ipv6"
+ "--with-debug"
+ ;; Even when not cross-building, we pass the
+ ;; --crossbuild option to avoid customizing for the
+ ;; kernel version on the build machine.
+ ,(let ((system "Linux") ; uname -s
+ (release "2.6.32") ; uname -r
+ ;; uname -m
+ (machine (match (or (%current-target-system)
+ (%current-system))
+ ("x86_64-linux" "x86_64")
+ ("i686-linux" "i686")
+ ("mips64el-linux" "mips64"))))
+ (string-append "--crossbuild="
+ system ":" release ":" machine)))))
+ (setenv "CC" "gcc")
+ (format #t "environment variable `CC' set to `gcc'~%")
+ (format #t "configure flags: ~s~%" flags)
+ (zero? (apply system* "./configure" flags))))))))
(home-page "http://nginx.org")
(synopsis "HTTP and reverse proxy server")
(description