summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-17 18:41:20 +0100
committerLudovic Courtès <ludo@gnu.org>2016-01-17 18:41:20 +0100
commitbb8afbf5a1fbc85f700c0e07ce5581637e3674dc (patch)
tree68aab4267ca02d5ad969fec6e965975675cd9ce4 /gnu/packages/web.scm
parentca3f9952d7090dbc894f715a5ecbb26309cffb44 (diff)
gnu: Add dependency on Perl's 'Module::Build' as needed.
'Module::Build' was deprecated in Perl 5.20 and removed in 5.22. Some packages need to explicitly depend on it now. * gnu/packages/perl.scm (perl-class-factory-util): (perl-date-manip, perl-devel-checkbin): Add 'native-inputs' field. (perl-module-build)[description]: Mention that it used to be in Perl. * gnu/packages/web.scm (perl-cgi-simple)[native-inputs]: Add PERL-MODULE-BUILD.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 52c5740388..7f95d82844 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Aljosha Papsch <misc@rpapsch.de>
-;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
@@ -1558,7 +1558,8 @@ development server with Starman.")
"1nkyb1m1g5r47xykflf68dplanih5p15njv82frbgbsms34kp1sg"))))
(build-system perl-build-system)
(native-inputs
- `(("perl-io-stringy" ,perl-io-stringy))) ;for IO::Scalar
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-io-stringy" ,perl-io-stringy))) ;for IO::Scalar
(home-page "http://search.cpan.org/dist/CGI-Simple")
(synopsis "CGI interface that is CGI.pm compliant")
(description "CGI::Simple provides a relatively lightweight drop in