summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-25 15:56:56 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-14 14:06:29 +0100
commite1c63590efef7cf383994253b07e81d3e27f3a54 (patch)
tree1381f16f8ed511b3bd13c4ad8207235d199f8c32 /gnu/packages/web.scm
parent3996f0aadc675a19db74503563fb98ee18734297 (diff)
gnu: Add Gumbo Parser.
* gnu/packages/web.scm (gumbo-parser): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6c3329ffb6..e6659ec148 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3003,3 +3003,34 @@ the package implements a framework for performing fully customized requests
where data can be processed either in memory, on disk, or streaming via the
callback or connection interfaces.")
(license l:expat)))
+
+(define-public gumbo-parser
+ (package
+ (name "gumbo-parser")
+ (version "0.10.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/google/"
+ "gumbo-parser/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bgg2kbj311pqdzw2v33za7k66g1rv44kkvvnz2gnpaasi9k0ii8"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; tests require bundling googletest sources
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _ (zero? (system* "sh" "autogen.sh")))))))
+ ;; The release tarball lacks the generated files.
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "https://github.com/google/gumbo-parser")
+ (synopsis "HTML5 parsing library")
+ (description
+ "Gumbo is an implementation of the HTML5 parsing algorithm implemented as
+a pure C99 library.")
+ (license l:asl2.0)))