summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2022-08-13 16:47:31 +0530
committerArun Isaac <arunisaac@systemreboot.net>2022-08-13 17:17:47 +0530
commitff564de64cdd4bd3d6d578b0beeefef1d062e68f (patch)
tree85a5927f400a2c48664b14667f5cc4aa00eea8fd /gnu/packages/web.scm
parent1e51cb37fb15c5d66a536dea7981c982915400b6 (diff)
gnu: kiwix-lib: Update to 11.0.0.
* gnu/packages/web.scm (kiwix-lib): Update to 11.0.0. [arguments]: Do not explicitly pass mustache path to CPPFLAGS. Do not return #t from phases. Use search-input-file. [native-inputs]: Remove labels. Use cpp-mustache package instead of its source.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm28
1 files changed, 9 insertions, 19 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index c4eac670e8..8c7df5af1e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -109,6 +109,7 @@
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages crates-gtk)
#:use-module (gnu packages crates-io)
#:use-module (gnu packages curl)
@@ -7986,7 +7987,7 @@ for ZIM files.")
(define-public kiwix-lib
(package
(name "kiwix-lib")
- (version "9.4.1")
+ (version "11.0.0")
(home-page "https://github.com/kiwix/kiwix-lib/")
(source (origin
(method git-fetch)
@@ -7995,7 +7996,7 @@ for ZIM files.")
(commit version)))
(sha256
(base32
- "034nk6l623v78clrs2d0k1vg69sbzrd8c0q79qiqmlkinck1nkxw"))
+ "1w5dabzvd3cnhw064qf9166476fszkkxjcml21x35av0dcd1vlk6"))
(file-name (git-file-name name version))))
(build-system meson-build-system)
(arguments
@@ -8003,13 +8004,11 @@ for ZIM files.")
(modify-phases %standard-phases
(add-before 'configure 'fix-paths-and-includes
(lambda* (#:key inputs #:allow-other-keys)
- (setenv "CPPFLAGS" (string-append "-I" (assoc-ref inputs "mustache")))
(substitute* "src/aria2.cpp"
(("ARIA2_CMD \"aria2c\"")
(string-append "ARIA2_CMD \""
- (assoc-ref inputs "aria2")
- "/bin/aria2c\"")))
- #t)))))
+ (search-input-file inputs "/bin/aria2c")
+ "\""))))))))
(inputs
(list aria2
curl
@@ -8021,19 +8020,10 @@ for ZIM files.")
zlib
`(,zstd "lib")))
(native-inputs
- `(("mustache" ,(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kainjow/Mustache")
- ;; XXX: Readme says to use version 3. Can we use 3.2.1?
- (commit "v4.1")))
- (file-name (git-file-name "mustache" "4.1"))
- (sha256
- (base32
- "0r9rbk6v1wpld2ismfsk2lkhbyv3dkf0p03hkjivbj05qkfhvlbb"))))
- ("pkg-config" ,pkg-config)
- ;; for kiwix-compile-resources
- ("python" ,python-wrapper)))
+ (list cpp-mustache
+ pkg-config
+ ;; for kiwix-compile-resources
+ python-wrapper))
(synopsis "Common code base for all Kiwix ports")
(description "The Kiwix library provides the Kiwix software suite core.
It contains the code shared by all Kiwix ports.")