summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-17 13:51:05 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-17 14:38:32 +0200
commitff690faf66d8f37ee6b679fcb7cf37e369624ee3 (patch)
tree3d6ab4ebded5a48f349ca5701643699e178481b4 /gnu/packages/web.scm
parent52f2980fa3feaf6e59b9e5144391faf8feb52a87 (diff)
gnu: Use target-hurd?, system-hurd? instead of hurd-target?, hurd-system?.
* gnu/packages/hurd.scm (hurd-target?): Remove. (hurd-system?): Move to... * guix/utils.scm (system-hurd?): ...here. * gnu/packages/*: Update all users, removing (gnu packages hurd) include where now unused.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index daa569263b..f5b6c8cd2f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -40,7 +40,7 @@
;;; Copyright © 2019, 2020 Florian Pelz <pelzflorian@pelzflorian.de>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2020, 2021 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020, 2021, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2018, 2019, 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2020, 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
@@ -142,7 +142,6 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
- #:use-module (gnu packages hurd)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages java)
@@ -7785,7 +7784,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
(inputs
;; Required to build the tools (i.e. without ‘--enable-lib-only’).
(append
- (if (hurd-target?)
+ (if (target-hurd?)
`((,openssl "static"))
(list jemalloc)) ; fight nghttpd{,x} heap fragmentation
(list c-ares