summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorDiego Nicola Barbato <dnbarbato@posteo.de>2021-11-25 22:44:40 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-25 22:56:09 -0500
commitd13d5f3141df58e464f95ac42c2aa884a4f4d5ee (patch)
tree3618c2e1c492d5ff848af6b382ef0e7baf8af067 /gnu/packages/webkit.scm
parentb2022a09eb511422b8fc4562ae52f0647dd175ce (diff)
gnu: webkitgtk: Really disable SSE2 on non-x86_64 achitectures.
This is a followup to d82fd7c2dd542693988f61fb15c020e3209ac7ec. * gnu/packages/webkit.scm (webkitgtk)[phases]{disable-sse2}: Adjust. Co-authored-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 688e745d95..16096be57b 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -295,13 +295,6 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
(("libWPEBackend-fdo-([\\.0-9]+)\\.so" all version)
(string-append wpebackend-fdo "/lib/" all)))
#t)))
- ,@(if (string-prefix? "x86_64" (or (%current-target-system)
- (%current-system)))
- '()
- '((add-after 'unpack 'disable-sse2
- (lambda _
- (substitute* "Source/cmake/DetectSSE2.cmake"
- (("CHECK_FOR_SSE2\\(\\)") ""))))))
(add-before 'configure 'prepare-build-environment
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CC" "clang")
@@ -314,6 +307,13 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
"#define USE_MUL_OVERFLOW 0")))
'())
#t))
+ ,@(if (target-x86-64?)
+ '()
+ '((add-after 'unpack 'disable-sse2
+ (lambda _
+ (substitute* "Source/cmake/WebKitCompilerFlags.cmake"
+ (("WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING")
+ "FALSE"))))))
(add-after 'install 'move-doc-files
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))