summaryrefslogtreecommitdiff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-29 18:47:16 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-29 18:47:16 +0100
commit3bf428065916f1a47c5ed12f5622f0eff4123644 (patch)
treef424c57b8a00a019e04fc29f42c8527a811ba281 /gnu/packages/wget.scm
parent2cb64f3b1b3df338acfc0ba9f719875db21812b0 (diff)
parent683c5ab70accb909697717bb61741a7692c52c09 (diff)
Merge branch 'master' into python-build-system
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 80da33272e..72aab86c14 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,3 +61,36 @@ HTTPS and FTP protocols. It can resume interrupted downloads, use file name
wild cards, supports proxies and cookies, and it can convert absolute links
in downloaded documents to relative links.")
(license gpl3+))) ; some files are under GPLv2+
+
+(define-public wgetpaste
+ (package
+ (name "wgetpaste")
+ (version "2.28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://wgetpaste.zlin.dk/wgetpaste-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1hh9svyypqcvdg5mjxyyfzpdzhylhf7s7xq5dzglnm4injx3i3ak"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (zsh (string-append out "/share/zsh/site-functions")))
+ (install-file "wgetpaste" bin)
+ (install-file "_wgetpaste" zsh)))))
+ #:tests? #f)) ; no test target
+ (home-page "http://wgetpaste.zlin.dk/")
+ (synopsis "Script that automates pasting to a number of pastebin services")
+ (description
+ "@code{wgetpaste} is an extremely simple command-line interface to various
+online pastebin services.")
+ (license public-domain)))