summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorTrevor Richards <trev@trevdev.ca>2022-12-23 20:54:36 -0800
committerGuillaume Le Vaillant <glv@posteo.net>2023-01-02 15:50:20 +0100
commit8aa104752cb6a61f2ac689c31ac627ccab32f7fe (patch)
tree15ab8a61be1ab88a2dcd04dbe5489b9780a2b42b /gnu/packages/wm.scm
parent8156216b4a5adef3539824782c0598ecaac25fba (diff)
gnu: Add sbcl-stumpwm-battery-portable.
* gnu/packages/wm.scm (sbcl-stumpwm-battery-portable): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 18fe606c7b..a13467663e 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -56,7 +56,7 @@
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 Elais Player <elais@fastmail.com>
-;;; Copyright © 2022 Trevor Richards <trev@trevdev.ca>
+;;; Copyright © 2022, 2023 Trevor Richards <trev@trevdev.ca>
;;; Copyright © 2022 Fredrik Salomonsson <plattfot@posteo.net>
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
@@ -2358,6 +2358,25 @@ interface[fn:dbus-spec]. It shows notifications using stumpwm:message
by default.")
(license license:gpl3+)))
+(define-public sbcl-stumpwm-battery-portable
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-battery-portable")
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-cl-ppcre
+ (list stumpwm "lib")))
+ (arguments
+ '(#:asd-systems '("battery-portable")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "modeline/battery-portable"))))))
+ (synopsis "Battery level indicator for StumpWM")
+ (description "This module provides a battery level indicator for the
+modeline. It can be displayed in the modeline with %B.")
+ (license (list license:expat license:gpl3+))))
+
(define-public lemonbar
(package
(name "lemonbar")