summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorDariqq <dariqq@posteo.net>2024-06-02 16:41:00 +0000
committerChristopher Baines <mail@cbaines.net>2024-06-11 11:43:38 +0100
commit1d5bfe45134259676e609020ac64cbc1a1a81d2b (patch)
tree25457972c677206d7fee9b0a888cf1b0e2fab8a5 /gnu/packages/xdisorg.scm
parent0daa72e34d7fafc927e2d476ef613c582107781d (diff)
gnu: libwacom: Update to 2.11.0.
With the 2.9 release the license got clarified to be hpnd. * gnu/packages/xdisorg.scm (libwacom): Update to 2.11.0. [native-inputs]: Remove python-evdev. [inputs]: Add python, python-libevdev, python-pyudev. [propagated-inputs]: Add libevdev. [license]: Correct license to hpnd. Change-Id: Ib5276beaec2c23e74532cb157225fc3a9a2e25e7 Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d8b2551767..dc31cedeba 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1451,7 +1451,7 @@ Escape key when Left Control is pressed and released on its own.")
(define-public libwacom
(package
(name "libwacom")
- (version "2.6.0")
+ (version "2.11.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1459,7 +1459,7 @@ Escape key when Left Control is pressed and released on its own.")
"libwacom-" version "/libwacom-" version ".tar.xz"))
(sha256
(base32
- "13x978gzyw28cqd985m5smiqgza0xp3znb1s0msmn8vmjjlwqxi3"))))
+ "0i0k333kfc6ai4vxqijjybj38s9j1hly2x327113lm1cr0g9jgxh"))))
(build-system meson-build-system)
(arguments
(list
@@ -1468,15 +1468,19 @@ Escape key when Left Control is pressed and released on its own.")
(list pkg-config
;; For tests.
python
- python-evdev
python-libevdev
python-pytest
python-pyudev))
(inputs
- (list gtk+ eudev libxml2))
+ (list gtk+
+ eudev
+ libxml2
+ python
+ python-libevdev
+ python-pyudev))
(propagated-inputs
;; libwacom.pc 'Requires' these:
- (list glib libgudev))
+ (list glib libevdev libgudev))
(home-page "https://linuxwacom.github.io/")
(synopsis "Helper library for graphics tablet settings")
(description
@@ -1484,7 +1488,7 @@ Escape key when Left Control is pressed and released on its own.")
intended to be used by client-programs that need model identification. It is
already being used by the gnome-settings-daemon and the GNOME Control Center
Wacom tablet applet.")
- (license license:x11)))
+ (license license:hpnd)))
(define-public xf86-input-wacom
(package