summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorIvan Kozlov <kanichos@yandex.ru>2020-07-12 22:19:35 +0200
committerLudovic Courtès <ludo@gnu.org>2020-07-12 22:40:50 +0200
commit7bbe4655a8726a7250837c01c2678d7bcc6262e6 (patch)
treee563fef08d527c39ab1e40ff83b8ba6dede4d4e3 /gnu/packages/xdisorg.scm
parent060211853d3f18f9d582549fcfb803e9ec8d2837 (diff)
gnu: Add xssproxy.
* gnu/packages/xdisorg.scm (xssproxy): New variable.
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index dafc63b5ca..6033b40380 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Boris A. Dekshteyn <boris.dekshteyn@gmail.com>
;;; Copyright © 2020 Alex McGrath <amk@amk.ie>
+;;; Copyright © 2020 Ivan Kozlov <kanichos@yandex.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1360,6 +1361,44 @@ demos. It also acts as a nice screen locker.")
"http://metadata.ftp-master.debian.org/changelogs/"
"/main/x/xscreensaver/xscreensaver_5.36-1_copyright")))))
+(define-public xssproxy
+ (package
+ (name "xssproxy")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/timakro/xssproxy")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0c83wmipnsdnbihc5niyczs7jrkss2s8n6iwwjdia7hkjzbd0hl7"))))
+ (build-system gnu-build-system)
+ (arguments `(#:make-flags `("bindir=/bin"
+ "man1dir=/share/man/man1"
+ ,(string-append "DESTDIR=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxscrnsaver" ,libxscrnsaver)
+ ("dbus" ,dbus)))
+ (synopsis "Forward freedesktop.org Idle Inhibition Service calls to Xss")
+ (description "xssproxy implements the @code{org.freedesktop.ScreenSaver}
+D-Bus interface described in the Idle Inhibition Service Draft by the
+freedesktop.org developers. The inhibition of the screensaver is then
+controlled using the XScreenSaverSuspend function from the Xss (X11 Screen
+Saver extension) library.")
+ (home-page "https://github.com/timakro/xssproxy")
+ (license license:gpl3+)))
+
(define-public xsel
(package
(name "xsel")