summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-12-10 19:13:46 +0800
committer宋文武 <iyzsong@gmail.com>2014-12-12 20:13:07 +0800
commit471dbb70f9a4d3560c5dfb7140afd099e33f8046 (patch)
treef5b8992482664a22993d634ce2f7ae43f69cefab /gnu/packages/xfce.scm
parent79c2528ffbe4ce8a4a0258a21b910cef19aa3fc0 (diff)
gnu: Add xfconf.
* gnu/packages/xfce.scm (xfconf): New variable.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index c570d722b7..4269158f7d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -71,3 +71,33 @@
"A general-purpose utility library with core application support for the
Xfce Desktop Environment.")
(license lgpl2.0+)))
+
+(define-public xfconf
+ (package
+ (name "xfconf")
+ (version "4.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/xfce/"
+ (version-major+minor version)
+ "/src/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0xh520z0qh0ib0ijgnyrgii9h5d4pc53n6mx1chhyzfc86j1jlhp"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (propagated-inputs
+ ;; libxfconf-0.pc refers to all these.
+ `(("glib" ,glib)
+ ("dbus" ,dbus)
+ ("dbus-glib" ,dbus-glib)))
+ (inputs
+ `(("libxfce4util" ,libxfce4util)))
+ (home-page "http://www.xfce.org/")
+ (synopsis "Configuration storage and query system for Xfce")
+ (description
+ "Settings daemon for Xfce, implemented as a D-Bus-based configuration
+storage system.")
+ (license lgpl2.0+)))