summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2021-01-15 01:00:47 +0100
committerLudovic Courtès <ludo@gnu.org>2021-01-16 22:59:08 +0100
commite13f90580c0edc6c8b3731d959dcff0b1402e106 (patch)
treec443899ee142fceb23c999e7274445b4eb03a59d /gnu/packages/xfce.scm
parentd08a292ad8981e5938c40463a45ab7bced628d63 (diff)
gnu: xfconf: Install bash completion.
* gnu/packages/xfce.scm (xfconf)[arguments]: Add install-shell-completions phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 2736f861a8..77c366b0a2 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -155,6 +155,13 @@ Xfce Desktop Environment.")
;; For the missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0")
(invoke "dbus-launch" "make" "check")))
+ (add-after 'custom-check 'install-shell-completions
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (etc (string-append out "/etc")))
+ (with-directory-excursion "completions"
+ (install-file "xfconf-query"
+ (string-append etc "/bash_completion.d"))))))
(delete 'check))))
(native-inputs
`(("pkg-config" ,pkg-config)