summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-12-24 19:11:30 -0500
committerLeo Famulari <leo@famulari.name>2016-12-24 19:19:36 -0500
commit3a2bcac6bd5a372553079750717ed4e9e6a638f1 (patch)
treedcb0041b1483f56602d998cbc68a5d150ffeee6c /gnu/packages/xml.scm
parent0c83c6bf2669367e81012391b5bc4ab0406ffbf3 (diff)
gnu: libxml2: Fix CVE-2016-5131.
* gnu/packages/patches/libxml2-CVE-2016-5131.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/xml.scm (libxml2/fixed)[source]: Add it.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index d821338b52..32b658489c 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -108,7 +108,8 @@ project (but it is usable outside of the Gnome platform).")
(source
(origin
(inherit (package-source libxml2))
- (patches (search-patches "libxml2-CVE-2016-4658.patch"))))))
+ (patches (search-patches "libxml2-CVE-2016-4658.patch"
+ "libxml2-CVE-2016-5131.patch"))))))
(define-public python-libxml2
(package (inherit libxml2)