summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorAndy Tai <ltai@roku.com>2023-09-27 09:36:13 -0700
committerLudovic Courtès <ludo@gnu.org>2023-09-28 11:44:09 +0200
commitbe9b7e0f653e27030c402194c7020aea873f30a5 (patch)
tree513e46abd8fac05a38297193c84596d57d4398fb /gnu/packages/xorg.scm
parentfe7b5df00ccecd46b6c06f5fef4fe42a5c8536be (diff)
gnu: xpra: Update to 5.0.2
* gnu/packages/patches/xpra-4.2-install_libs.patch: Move to ... * gnu/packages/patches/xpra-5.0-install_libs.patch: ... this file. * gnu/packages/patches/xpra-4.2-systemd-run.patch: Move to ... * gnu/packages/patches/xpra-5.0-systemd-run.patch: ... this file. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/xorg.scm (xpra): Update to 5.0.2. [source] <patches>: Rename per version changes [inputs]: Add cups. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index cd1335661b..ec846093e2 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -72,6 +72,7 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cups)
#:use-module (gnu packages compression)
#:use-module (gnu packages emacs)
#:use-module (gnu packages flex)
@@ -6110,16 +6111,16 @@ basic eye-candy effects.")
(define-public xpra
(package
(name "xpra")
- (version "4.4.6")
+ (version "5.0.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.xpra.org/src/xpra-"
version ".tar.xz"))
(sha256
- (base32 "0d3s13wqbn9jwqp4i55mn4chgjkrckq3jx4jrq1bcjjz5agzfrq5"))
- (patches (search-patches "xpra-4.2-systemd-run.patch"
- "xpra-4.2-install_libs.patch"))))
+ (base32 "0gxv0h1spg2jl3g9cc6qxxkq6a7prmb92dqqwk0s6pvrj8w3izlk"))
+ (patches (search-patches "xpra-5.0-systemd-run.patch"
+ "xpra-5.0-install_libs.patch"))))
(build-system python-build-system)
(inputs
(list bash-minimal ; for wrap-program
@@ -6158,7 +6159,8 @@ basic eye-candy effects.")
python-dbus ; For desktop notifications.
dbus ; For dbus-launch command.
python-lz4 ; Faster compression than zlib.
- python-netifaces))
+ python-netifaces
+ python-pycups))
(native-inputs (list pkg-config pandoc python-cython))
(arguments
(list
@@ -6193,7 +6195,7 @@ basic eye-candy effects.")
(format #f "~s" (search-input-file inputs "bin/xauth"))))
;; Fix directory of config files.
(substitute* '("xpra/scripts/config.py"
- "xpra/platform/xposix/paths.py")
+ "xpra/platform/posix/paths.py")
(("\"/etc/xpra/?\"")
(string-append "\"" #$output "/etc/xpra/\"")))
;; XXX: Stolen from (gnu packages linux)