summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorpjotrp <pjotr.public01@thebird.nl>2015-07-04 15:00:09 +0200
committerDavid Thompson <davet@gnu.org>2015-07-04 09:47:33 -0400
commit022170dca1ca223b449fc03f05f80db9d691c230 (patch)
tree65d07d2d74eb93f9520f6327ce785554b543843b /gnu/packages
parent80e907fe574c8901f32c5f5068ee1e7d0dda292d (diff)
gnu: Add ruby-rake-compiler.
* gnu/packages/ruby.scm (ruby-rake-compiler): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index af87cf551f..7823ee4197 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -177,6 +177,36 @@ announcement.")
(home-page "http://www.zenspider.com/projects/hoe.html")
(license license:expat)))
+(define-public ruby-rake-compiler
+ (package
+ (name "ruby-rake-compiler")
+ (version "0.9.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/rake-compiler/rake-compiler/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "07lk1vl0jqcaqwjjhmg0qshqwcxdyr5kscc9xxm13m03835xgpf3"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f ; needs cucumber
+ #:phases (modify-phases %standard-phases
+ (add-before 'build 'remove-cucumber-rake-task
+ (lambda _
+ ;; Remove cucumber test file because the
+ ;; dependencies are not available right now.
+ (delete-file "tasks/cucumber.rake")))
+ (replace 'build
+ (lambda _ (zero? (system* "rake" "gem")))))))
+ (synopsis "Building and packaging helper for Ruby native extensions")
+ (description "Rake-compiler proivides a framework for building and
+packaging native C and Java extensions in Ruby.")
+ (home-page "https://github.com/rake-compiler/rake-compiler")
+ (license license:expat)))
+
(define-public ruby-i18n
(package
(name "ruby-i18n")