summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-21 07:34:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-21 23:05:52 +0200
commit02deb211379cd987a7fa0a3ee0171a84b310dac0 (patch)
tree5cee681bc669f61192a2a2f0ea5667c5aefda60c /gnu/packages
parent04c716afa56de3b8ff2b4e98673ddd4544720914 (diff)
gnu: openssl@1: Update to 1.1.1n and remove replacement.
* gnu/packages/tls.scm (openssl): Update to 1.1.1n. [replacement]: Remove. (openssl/fixed): Remove.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tls.scm24
1 files changed, 2 insertions, 22 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index cf50a88410..bd1f010d0a 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -384,8 +384,7 @@ OpenSSL for TARGET."
(define-public openssl
(package
(name "openssl")
- (version "1.1.1l")
- (replacement openssl/fixed)
+ (version "1.1.1n")
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -398,7 +397,7 @@ OpenSSL for TARGET."
(patches (search-patches "openssl-1.1-c-rehash-in.patch"))
(sha256
(base32
- "1lbblxps2fhmz7bqh058iywh5wxfignbfx1s1kz2fj63b5g3wyhb"))))
+ "0ymif8rlc5cf5qp5bh2pxlrgq6xryh7g4sqfvrdjg9gnli8ypp20"))))
(build-system gnu-build-system)
(outputs '("out"
"doc" ;6.8 MiB of man3 pages and full HTML documentation
@@ -503,25 +502,6 @@ OpenSSL for TARGET."
(license license:openssl)
(home-page "https://www.openssl.org/")))
-(define openssl/fixed
- (package
- (inherit openssl)
- (name "openssl")
- (version "1.1.1n")
- (source (origin
- (method url-fetch)
- (uri (list (string-append "https://www.openssl.org/source/openssl-"
- version ".tar.gz")
- (string-append "ftp://ftp.openssl.org/source/"
- "openssl-" version ".tar.gz")
- (string-append "ftp://ftp.openssl.org/source/old/"
- (string-trim-right version char-set:letter)
- "/openssl-" version ".tar.gz")))
- (patches (search-patches "openssl-1.1-c-rehash-in.patch"))
- (sha256
- (base32
- "0ymif8rlc5cf5qp5bh2pxlrgq6xryh7g4sqfvrdjg9gnli8ypp20"))))))
-
(define-public openssl-3.0
(package
(inherit openssl)