summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-05-07 22:58:13 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-16 21:43:53 +0100
commit09535959a9d17f0d327f3454dc78c0be1f7b43e4 (patch)
treef105aee34bec4b09734d10fd55dd0f6cd20c651f /gnu/packages
parentcc97cec5dd90f8d6cee3773b31b09c09f95b2cb0 (diff)
gnu: Add go-github-com-pion-rtp.
* gnu/packages/golang-web.scm (go-github-com-pion-rtp): New variable. Change-Id: I99f1a4363cf5cb5c5ee2ffd7c6aa589107e71de0 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 0d819eed3c..013ab933c8 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1588,6 +1588,33 @@ which produce colorized output using github.com/fatih/color.")
(description "OpenTracing-Go is a Go implementation of the OpenTracing API.")
(license license:asl2.0)))
+(define-public go-github-com-pion-rtp
+ (package
+ (name "go-github-com-pion-rtp")
+ (version "1.8.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/rtp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vrdvswvvbqq83kbjlyblarbsn5v0sjcwrcv03nncd605cggnbkx"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/pion/rtp"))
+ (propagated-inputs
+ (list go-github-com-pion-randutil))
+ (home-page "https://github.com/pion/rtp")
+ (synopsis "Go implementation of RTP")
+ (description
+ "This package provides a @acronym{Real-time Transport Protocol, RTP}
+packetizer and depacketizer.")
+ (license license:expat)))
+
(define-public go-github-com-pires-go-proxyproto
(package
(name "go-github-com-pires-go-proxyproto")