summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-04 07:15:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-04 07:27:43 +0200
commit11108a9ab459668ee1ba81a6fbca64d224d35365 (patch)
treeb6b408561144fb07dece0cc7139f947684d6abec /gnu/packages
parentfadf5765c1a44c03144007737877f6d3abb8332a (diff)
gnu: Add r-googledrive.
* gnu/packages/cran.scm (r-googledrive): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b92a8258aa..68a2dff47a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -175,6 +175,37 @@ automatically pruning objects to maintain the constraints.")
visualization of their differences.")
(license license:gpl2+)))
+(define-public r-googledrive
+ (package
+ (name "r-googledrive")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "googledrive" version))
+ (sha256
+ (base32
+ "0qbyl0wyrxmwn9jg0d2s7c1kmmvmx61qbyx3qby4js8dks70f1ls"))))
+ (properties `((upstream-name . "googledrive")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-curl" ,r-curl)
+ ("r-gargle" ,r-gargle)
+ ("r-glue" ,r-glue)
+ ("r-httr" ,r-httr)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-magrittr" ,r-magrittr)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)
+ ("r-uuid" ,r-uuid)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://googledrive.tidyverse.org")
+ (synopsis "Interface to Google Drive")
+ (description "This package lets you manage Google Drive files from R.")
+ (license license:expat)))
+
(define-public r-waldo
(package
(name "r-waldo")