summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-03-28 15:35:56 +0200
committerLudovic Courtès <ludo@gnu.org>2023-03-30 12:44:21 +0200
commit14cd517e0cb8829b06b5a49f91c762c4a0e52eb5 (patch)
tree1a840adc595d9ac8b76847ba4f364978f06b523c /gnu/packages
parent0b2d1fd41096cb394064bfa3e599c7024904ec97 (diff)
gnu: guile: Fix 'posix_spawn' usage for GNU/Hurd.
* gnu/packages/guile.scm (guile-3.0)[arguments]: Add 'patch-posix-spawn-usage' phase. * gnu/packages/patches/guile-hurd-posix-spawn.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/guile.scm10
-rw-r--r--gnu/packages/patches/guile-hurd-posix-spawn.patch44
2 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 8e52448d36..8d25614e3a 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -371,6 +371,16 @@ without requiring the source code to be rewritten.")
(("!#")
"!#\n(exit 77)\n"))))
+ #$@(if (target-hurd?)
+ #~((add-before 'build 'patch-posix-spawn-usage
+ (lambda _
+ ;; TODO: Move patch to 'source' on next rebuild
+ ;; cycle.
+ (define patch
+ #$(local-file
+ (search-patch "guile-hurd-posix-spawn.patch")))
+ (invoke "patch" "--force" "-p1" "-i" patch))))
+ #~())
#$@(if (target-ppc32?)
#~((add-after 'unpack 'adjust-bootstrap-flags
(lambda _
diff --git a/gnu/packages/patches/guile-hurd-posix-spawn.patch b/gnu/packages/patches/guile-hurd-posix-spawn.patch
new file mode 100644
index 0000000000..7cf600b4c2
--- /dev/null
+++ b/gnu/packages/patches/guile-hurd-posix-spawn.patch
@@ -0,0 +1,44 @@
+Fix <https://issues.guix.gnu.org/61095>, which affects GNU/Hurd.
+
+diff --git a/libguile/posix.c b/libguile/posix.c
+index 3a8be94e4..f5fdc544c 100644
+--- a/libguile/posix.c
++++ b/libguile/posix.c
+@@ -1326,7 +1326,14 @@ static void
+ close_inherited_fds_slow (posix_spawn_file_actions_t *actions, int max_fd)
+ {
+ while (--max_fd > 2)
+- posix_spawn_file_actions_addclose (actions, max_fd);
++ {
++ /* Adding invalid file descriptors to an 'addclose' action leads
++ to 'posix_spawn' failures on some operating systems:
++ <https://bugs.gnu.org/61095>. Hence the extra check. */
++ int flags = fcntl (max_fd, F_GETFD, NULL);
++ if ((flags >= 0) && ((flags & FD_CLOEXEC) == 0))
++ posix_spawn_file_actions_addclose (actions, max_fd);
++ }
+ }
+
+ static void
+
+Fix <https://issues.guix.gnu.org/62501>.
+
+diff --git a/test-suite/tests/posix.test b/test-suite/tests/posix.test
+index f20e04453..d5cf47cda 100644
+--- a/test-suite/tests/posix.test
++++ b/test-suite/tests/posix.test
+@@ -431,7 +431,13 @@
+ (let ((str (get-string-all (car input+output))))
+ (close-port (car input+output))
+ (waitpid pid)
+- str)))
++
++ ;; On GNU/Hurd, the exec server prepends 'LD_ORIGIN_PATH' for
++ ;; every program: <https://bugs.gnu.org/62501>. Strip it.
++ (if (and (string=? "GNU" (utsname:sysname (uname)))
++ (string-prefix? "LD_ORIGIN_PATH=" str))
++ (string-drop str (+ 1 (string-index str #\newline)))
++ str))))
+
+ (pass-if-equal "ls /proc/self/fd"
+ "0\n1\n2\n3\n" ;fourth FD is for /proc/self/fd