summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-17 00:38:15 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:05 +0000
commit1900b75c23fca2e748784b72ed6c9e25e7159bee (patch)
tree6e7f6b348aad29727e9face23e9e31455b4b504b /gnu/packages
parentbf30f46716d70d1e143a0a2a2c96ad2f212a3c19 (diff)
gnu: go-github-com-cespare-xxhash: Move to (gnu packages golang-crypto).
* gnu/packages/syncthing.scm (go-github-com-cespare-xxhash): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. * gnu/packages/textutils.scm: Add (gnu packages golang-crypto) to used modules. Change-Id: Ic72cf6c4770cd3f03cc2e27c3455632ee16e7c09
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-crypto.scm32
-rw-r--r--gnu/packages/syncthing.scm31
-rw-r--r--gnu/packages/textutils.scm1
3 files changed, 33 insertions, 31 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 00a6f51313..187f47b8eb 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2022 (unmatched-parenthesis <paren@disroot.org>
+;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022, 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
@@ -165,6 +166,37 @@ been designed so it can be used as a standalone package for any projects
needing to use secp256k1 elliptic curve cryptography.")
(license license:isc))))
+(define-public go-github-com-cespare-xxhash
+ (package
+ (name "go-github-com-cespare-xxhash")
+ (version "2.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cespare/xxhash")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1f3wyr9msnnz94szrkmnfps9wm40s5sp9i4ak0kl92zcrkmpy29a"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/cespare/xxhash"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (unless
+ ;; The tests fail when run with gccgo.
+ (false-if-exception (search-input-file inputs "/bin/gccgo"))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
+ (home-page "https://github.com/cespare/xxhash/")
+ (synopsis "Go implementation of xxHash")
+ (description "This package provides of Go implementation of the 64-bit
+xxHash algorithm (XXH64).")
+ (license license:expat)))
+
(define-public go-github-com-cloudflare-circl
(package
(name "go-github-com-cloudflare-circl")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 7598b46824..e3c0593aee 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1006,34 +1006,3 @@ virtual connections from a single physical connection.")
and RFC 5389).")
(home-page "https://github.com/ccding/go-stun")
(license asl2.0))))
-
-(define-public go-github-com-cespare-xxhash
- (package
- (name "go-github-com-cespare-xxhash")
- (version "2.1.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/cespare/xxhash")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1f3wyr9msnnz94szrkmnfps9wm40s5sp9i4ak0kl92zcrkmpy29a"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/cespare/xxhash"
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- (unless
- ;; The tests fail when run with gccgo.
- (false-if-exception (search-input-file inputs "/bin/gccgo"))
- (apply (assoc-ref %standard-phases 'check) args)))))))
- (synopsis "Go implementation of xxHash")
- (description "This package provides of Go implementation of the 64-bit
-xxHash algorithm (XXH64).")
- (home-page "https://github.com/cespare/xxhash/")
- (license expat)))
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 494e6b5ef5..96bc2e56cc 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -65,6 +65,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-check)
+ #:use-module (gnu packages golang-crypto)
#:use-module (gnu packages gettext)
#:use-module (gnu packages java)
#:use-module (gnu packages ncurses)