summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-01 00:45:50 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:56:21 +0200
commit1a6bc33d3fde087d24d24493aff9bf6b86a5c628 (patch)
treed5c2dfd6dc944ca9a2e11f9937021134020fae57 /gnu/packages
parent09fd9898c76c5f03019b987f0f62767d68e92ef6 (diff)
gnu: Add tslib.
* gnu/packages/video.scm (tslib): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/video.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 22547b78de..d3cf708e08 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -172,6 +172,40 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
+(define-public tslib
+ (package
+ (name "tslib")
+ (version "1.21")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/libts/tslib.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ph51vpfp92rpa2vs6wkz1b1pcs3z334p1i33sprsi8mjlwvkbzc"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "tests"
+ #:configure-flags
+ (list
+ "--with-sdl2")))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("linux-headers" ,linux-libre-headers)
+ ("sdl2" ,sdl2)))
+ (synopsis "Touchscreen access library")
+ (description "TSLib is a cross-platform library that provides access to
+touchscreen devices and the ability to apply filters to their input events.")
+ (home-page "http://www.tslib.org/")
+ (license license:lgpl2.1+)))
+
(define-public libmpeg3
(package
(name "libmpeg3")