summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 15:09:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:33 +0200
commit1e87a0cf99ed5d7a63d1b2a26c492cecbeb0fe76 (patch)
tree88d4ff591f0cd390d8851ef889bbbfbd5a59aee0 /gnu/packages
parent2bd23d2e262c96f9d167d53c3067c9954d752b8b (diff)
gnu: Add texlive-optex.
* gnu/packages/tex.scm (texlive-optex): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ec328238b8..d3c8e04fd2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11450,6 +11450,42 @@ and back-ends. It also ensures compatibility with the @code{media9} and
(define-deprecated-package texlive-latex-ocgx2 texlive-ocgx2)
+(define-public texlive-optex
+ (package
+ (name "texlive-optex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/optex.1"
+ "doc/man/man1/optex.man1.pdf"
+ "doc/optex/base/"
+ "tex/optex/base/"
+ "tex/optex/demo/"
+ "tex/optex/pkg/")
+ (base32
+ "0bcrj9wrimcd2pxrcfk7x3vkhxzij4422l19a8j4h299lkq3pbx0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:create-formats #~(list "optex")))
+ (propagated-inputs
+ (list texlive-amsfonts
+ texlive-cm
+ texlive-ec
+ texlive-hyphen-base
+ texlive-librarian
+ texlive-lm
+ texlive-luaotfload
+ texlive-luatex
+ texlive-rsfs
+ texlive-unicode-data))
+ (home-page "https://ctan.org/pkg/optex")
+ (synopsis "LuaTeX format based on Plain TeX and OPmac")
+ (description
+ "OpTeX is a LuaTeX format based on Plain TeX macros with power from
+OPmac (fonts selection system, colors, external graphics, references,
+hyperlinks, ...) with Unicode fonts.")
+ (license license:public-domain)))
+
(define-public texlive-ms
(package
(name "texlive-ms")