summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:49:54 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commit208094b49a297c178e9b5eef41edd0d9d273ea5e (patch)
tree6d85b292b22df4e6e9b06c4f61f42da87cdef0e6 /gnu/packages
parent5e22e8ed4d5df29dd199abd65f90d670ae43ea19 (diff)
gnu: kde-frameworks: Add modemmanager-qt.
* gnu/packages/kde-frameworks.scm (modemmanager-qt): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-frameworks.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 25b6a67e50..f38d5f1927 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -27,6 +27,7 @@
#:use-module (guix utils)
#:use-module (gnu packages admin)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages pkg-config)
@@ -816,6 +817,42 @@ lower level classes for interaction with the X Windowing System.")
;; the lgpl2.1. Some source files are under non-copyleft licenses.
(license license:lgpl2.1+)))
+(define-public modemmanager-qt
+ (package
+ (name "modemmanager-qt")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0khz5bf84xxa8aqpzwb6x839xx6dbiadwqhyj7cvgha65fh2xinh"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("dbus" ,dbus)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("modem-manager", modem-manager)
+ ("qtbase" ,qtbase)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* _
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (zero? (system* "dbus-launch" "ctest" ".")))))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Qt wrapper for ModemManager DBus API")
+ (description "ModemManagerQt provides access to all ModemManager features
+exposed on DBus. It allows you to manage modem devices and access to
+information available for your modem devices, like signal, location and
+messages.")
+ (license license:lgpl2.1+)))
+
(define-public oxygen-icons
(package
(name "oxygen-icons")