summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-27 22:40:52 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-27 23:00:59 +0100
commit25a9a26e0f94df0326ad65c6c1c744725549b4fd (patch)
treee8f4c92bc44d5ec74415faf6c0ec9f952f7cd788 /gnu/packages
parentf6b0023be5359855e9cd2efb663f0cbd62a251cc (diff)
gnu: emacs-bash-completion: Update to 3.1.1.
* gnu/packages/emacs-xyz.scm (emacs-bash-completion): Update to 3.1.1. [description]: Use proper capitalization.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm69
1 files changed, 32 insertions, 37 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7fe7cc5330..adb3633b6a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19072,43 +19072,38 @@ Slack client.")
(license license:gpl3+))))
(define-public emacs-bash-completion
- ;; Need to use a newer commit than the latest version in order to support
- ;; completion interfaces that alters the candidate list provided by the
- ;; package
- (let ((commit "c5eaeed156ab906190c662d491269230967104b1")
- (revision "0"))
- (package
- (name "emacs-bash-completion")
- (version (git-version "3.1.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/szermatt/emacs-bash-completion")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0r221iirqsbz13s76r68i496izbirrvcw8ql3wsh205zmxa3jqg1"))))
- (inputs (list bash))
- (build-system emacs-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'make-git-checkout-writable
- (λ _
- (for-each make-file-writable (find-files "."))))
- (add-before 'install 'configure
- (lambda* (#:key inputs #:allow-other-keys)
- (emacs-substitute-variables "bash-completion.el"
- ("bash-completion-prog"
- (search-input-file inputs "/bin/bash"))))))))
- (home-page "https://github.com/szermatt/emacs-bash-completion")
- (synopsis "Bash completion for the shell buffer")
- (description
- "@code{bash-completion} defines dynamic completion hooks for shell-mode
- and shell-command prompts that are based on Bash completion.")
- (license license:gpl2+))))
+ (package
+ (name "emacs-bash-completion")
+ (version "3.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/szermatt/emacs-bash-completion")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0cly0m6msn8xv9857nv4syw8fldqzvsa4kciq7av40y26a61hvrh"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ (λ _
+ (for-each make-file-writable (find-files "."))))
+ (add-before 'install 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (emacs-substitute-variables "bash-completion.el"
+ ("bash-completion-prog"
+ (search-input-file inputs "/bin/bash"))))))))
+ (inputs (list bash))
+ (home-page "https://github.com/szermatt/emacs-bash-completion")
+ (synopsis "Bash completion for the shell buffer")
+ (description
+ "Bash Completion defines dynamic completion hooks for Shell mode and
+@code{shell-command} prompts that are based on Bash completion.")
+ (license license:gpl2+)))
(define-public emacs-easy-kill
(package