summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-06-14 13:00:59 +0000
committerAlex Kost <alezost@gmail.com>2016-06-15 19:10:35 +0300
commit26e08b4d33918a844a42fd0f859ee640990ca757 (patch)
tree5c6c024120d9851e111b1e14f5ffb54d1f8565bf /gnu/packages
parent4714d521e3b5bcc6e2800ab377cb470cab09a595 (diff)
gnu: Add emacs-lua-mode.
* gnu/packages/emacs.scm (emacs-lua-mode): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 6a79412f7b..dfe2e2336f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2112,3 +2113,24 @@ There are plenty of differences between CIDER and SLIME, but the core ideas
are pretty much the same (and SLIME served as the principle inspiration for
CIDER).")
(license license:gpl3+)))
+
+(define-public emacs-lua-mode
+ (package
+ (name "emacs-lua-mode")
+ (version "20151025")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/immerrr/lua-mode/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0sbhfny5ib65cnx6xcy6h9bbw27mw034s8m9cca00bhxqaqi6p4v"))))
+ (build-system emacs-build-system)
+ (home-page "http://github.com/immerrr/lua-mode/")
+ (synopsis "Major mode for lua")
+ (description
+ "This Emacs package provides a mode for @uref{https://www.lua.org/,
+Lua programing language}.")
+ (license license:gpl2+)))