summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-05-07 17:57:23 +0200
committerAndreas Enge <andreas@enge.fr>2024-05-15 16:27:26 +0200
commit28ce5085a0a4191c27aecdc085600acf585b607c (patch)
treef193fca59adb9a150b644850ef60e90a4c13073e /gnu/packages
parent3b9e1cdc709155da7ac5dc5a13e60ea77fa5ef68 (diff)
gnu: frama-c: Update to 28.1.
* gnu/packages/maths.scm (frama-c): Update to 28.1. Change-Id: I0ce0d0a7db4d017ba1f5028e73c931ceb706fce5 Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1feabe5f1c..f2280cb392 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9542,14 +9542,14 @@ of C, Java, or Ada programs.")
(define-public frama-c
(package
(name "frama-c")
- (version "27.1")
+ (version "28.1")
(source (origin
(method url-fetch)
- (uri (string-append "http://frama-c.com/download/frama-c-"
- version "-Cobalt.tar.gz"))
+ (uri (string-append "https://frama-c.com/download/frama-c-"
+ version "-Nickel.tar.gz"))
(sha256
(base32
- "1lirkvhf5m53d33l0aw5jzc1fyzkwx5fkgh9g71732d52r55f4sv"))))
+ "14zmwghwhcryvri7k91vc1yampvxvhg36vwjxf64d8kx7dsbq802"))))
(build-system dune-build-system)
(arguments
`(#:phases
@@ -9572,6 +9572,7 @@ of C, Java, or Ada programs.")
ocaml-ppx-deriving-yojson
ocaml-ppx-deriving-yaml
ocaml-ppx-import
+ ocaml-unionfind
why3))
(native-inputs (list dune-site time ocaml-menhir ocaml-graph))
(native-search-paths